How to Build VyOS 1.2 with vyos-frr?

frr
vyos-1-2

#1

[color=#ffffff][size=small][font=arial, sans-serif]I want to build the latest VyOS version using vyos-frr instead of quagga as even following the instructions from the wiki on Debian Jessie.[/font][/size][/color]

[color=#ffffff][size=small][font=arial, sans-serif]However, the latest build still has quagga and I do not get frr daemon as given in the blog post:[/font][/size][/color]
[color=#ffffff][size=small][font=arial, sans-serif]http://blog.vyos.net/a-vyos-1-dot-2-0-alpha-image-with-frr-instead-of-quagga-is-available-for-testing-and-weve-found-a-gpl-violation-in-vyos [/font][/size][/color]

[color=#ffffff][size=small][font=arial, sans-serif]I tried to build it myself by adding vyos-frr submodule. However I got conflicts with vyatta-quagga_0.99.20.1-14+vyos2+current1_amd64.deb package.
[/font][/size][/color]

Here are the error logs:

Selecting previously unselected package vyatta-quagga.

Preparing to unpack …/vyatta-quagga_0.99.20.1-14+vyos2+current1_amd64.deb …

Unpacking vyatta-quagga (0.99.20.1-14+vyos2+current1) …

dpkg: error processing archive /var/cache/apt/archives/vyatta-quagga_0.99.20.1-14+vyos2+current1_amd64.deb (–unpack):

trying to overwrite ‘/usr/share/man/man1/vtysh.1.gz’, which is also in package frr 2.0

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

And at the end:

Processing triggers for systemd (215-17+deb8u7) …

Errors were encountered while processing:

/var/cache/apt/archives/vyatta-quagga_0.99.20.1-14+vyos2+current1_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

P: Begin unmounting filesystems…

P: Saving caches…

Reading package lists…

Building dependency tree…

Reading state information…

The iso partially built is unusable as it is a symbolic link:

vyos-999.201801121149-amd64.iso -> /home/user/New/vyos-build/build/live-image-amd64.hybrid.iso

[color=#ffffff][size=small][font=arial, sans-serif]Can anyone suggest steps to resolve?[/font][/size][/color]


#2

I also tried to install the vyos-frr deb package on a basic VyOS build but it was again met with conflicts and would not install.

Here is the screenshot: