how to start my vyos in openstack


#1

I wanna start my vyos in openstack,and I watched Brocade’s demo (https://www.youtube.com/watch?v=XB3WRl6-utY).And the vyos is created by press openstack horizon “creat route” button .and I try to install the Brocade Neutron L3 Plugin and my ubuntu just pop out many mistakes.I don’t know how to proceed. Can somebody help me?


#2

what does Brocade have to do with VyOS?


#3

I think you refer to this Neutron plugin: http://specs.openstack.org/openstack/neutron-specs/specs/juno/vyatta_l3_plugin.html
It seems that this plugin is aimed at the Brocade Vyatta vRouter as it does not mention VyOS. It may work by changing the vRouter image to a VyOS one, but I do not know which functionality is required from the image. The developers of the plugin may have a solution, but it may well be that Brocade developed it and therefore have no interest in adding VyOS support to it.

So far I have identified two main methods of getting VyOS running in OpenStack, none of which use the Brocade plugin:

  1. Boot from iso, and use OpenStack’s VNC to go through the install process
  2. Install on some other platform and import the (hdd) image to OpenStack

These methods will start VyOS as instances (hosts) on open stack. Afaik there is no (simple) way of using VyOS as replacement of the OS::Neutron::Router, so you will have to do some manual configuration and changes to your network topology.
If there is a better and more automated way of doing things, such as initial interface configuration, I am very interested in learning about it.


#4

My openstack is juno and it is running in a vmware virtual environment,
1.I tried to “install system” in openstack ,and there is no sda,there is only vda accessible, so I can not finish in my openstack. I want to know if I install cinder in openstack,there is sda accessible?
2.I also tried “install system” in virtualbox in my PC, and convert to “raw” and “qcow”,Then I import the image to openstack , But there is a big problem: my vyos can’t get the eth interface that neutron give to it,and I write the eth interface in /etc/conf/conf.boot and the interfaces information show up.But I think the interfaces can’t work.I still can’t ping the others.