How to use VyOS image in Cisco VIRL?


#1

I tried the VyOS KVM 1.5.1 virtual image. In Cisco VIRL, I choose generic but I’m getting a failure.

Has anyone been able to use a VyOS image in Cisco VIRL?

Thanks!!! Todd


#2

What are the specifics of the failure?


#3

The specifics are:

I’m running the latest Cisco VIRL (GUI VM Maestro Version: 1.2.1, Build ID: dev-128 and VIRL core 0.9.17).

I’m using the Web browser GUI interface to try and import a KVM image manually (User Workspace Manager -> Images -> Add)
-> Subtype: generic
-> Source KVM image: VyOs version 1.1.5 KVM x32 version from http://mirror.vyos.net/iso/release/1.1.5/vyos-1.1.5-i586-virt.iso

I then click on the create button.

I then get the error, “Failed to create image “generic”: The retrieved VM image type was not recognized. Please make sure that the correct file was specified and that there is no misconfigured http proxy standing in between. RAW-style images are not supported and will be rejected.”

I’m not using a proxy so you can ignore that part of the message.

I then download the image and source the image from my local hard drive.

However, I get the same identical error message.

In the above, I was running a remote web browser client, from my PC.

I then run a web browser, from the VIRL host itself. I had the same exact error message.

Thanks!!! Todd

Regards and Thanks!!! Todd


#4

I now realize that I needed to convert the KVM VyOs.iso to .img. However, I’m getting the same error message. To convert it, I did:

sudo virt-manager
os: Linux
version: Debian Squeeze
ram: 512
cpu: 1
disk: 2GB
Created: /var/lib/libvirt/images/vyos3.img

However, I still get the error message. I suggest you put this issue on hold. There is apparently a Brocade supported image for Cisco VIRL. I have the same problem with the supported image. Let me get the supported Brocade image working and then I’ll immediately retest the vyos image (since it may be a problem in common).

Thanks for waiting!

Regards, Todd


#5

I now have VyOs 1.1.5 working with Cisco VIRL. The problem was virt-manager created a default disk type of RAW, which Cisco VIRL does not support. So here is what worked for me:

Updated Cisco VIRL to the new April, 2015 release.
Used virt-manager to create a bootable vm guest (VyOs).
iso input: vyos-1.1.5-i586-virt.iso
os: Linux
version: Debian Squeeze
ram: 512
cpu: 1
disk: 2GB
disk format: qcow2
Created: /var/lib/libvirt/images/vyos9.img

During Cisco VIRL image input, choose generic and:
name the generic as vyos
config_disk_type = disk
hw_vif_model = virtio
hw_disk_bus = virtio

During running of Cisco VIRL, configure VyOs as:
node subtype: vyatta
vm image: choose the generic-vyos
vm flavor: choose the vyatta

Regards, Todd