inconsistency in wirelessmodem wlm interface behavior (could be bug?)


#1

Friends,

Something interesting and strange while bringing up 3G LTE interface, even though the interface is configred as wlm0, Vvyos brings it is as ppp0 and whereas wlm0 is displayed as inactive. Could it due to some bug? Please correct me if I am wrong.

Here is my configuration to enable wlm0 LTE interface and the airtel modem network

wirelessmodem wlm0 {
device ttyUSB4
network airtel
no-dns
}

‘’ AT
OK ATZ
OK ‘AT+CGDCONT=1,“IP”,“airtelgprs.com”,"",0,0,0,0,0,0’
OK ‘ATD99**1#’
CONNECT ‘’

1). NetworkManager brought up the ppp0 interface and got an IP address from the provider. Confirmed from the console logs as well as Unix admin “ifconfig -a” command.
The issue is while executing operational command for “show interfaces”, Vyos doesn’t show neither ‘wlm0’ nor ‘ppp0’. Why?

ppp0 Link encap:Point-to-Point Protocol
inet addr:100.88.8.84 P-t-P:10.64.64.64 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:266 (266.0 B) TX bytes:265 (265.0 B)
-----------
vyos@vyos:~$ show interfaces
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface IP Address S/L Description
--------- ---------- — -----------
eth0 - A/D
eth1 - u/D
eth2 - u/D
eth3 - u/D
eth4 - u/D
eth5 - u/D
lo 127.0.0.1/8 u/u
::1/128

2). I went ahead, ran operation command “show ip route”, vyos added a route for wlm0 that is correct, but it is showing ‘wlm0’ as inactive that is not correct. Another issue is ppp0 interface route got added, it should be ‘wlm0’. Please correct me.

vyos@vyos:~$ show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route
S 0.0.0.0/0 [10/0] is directly connected, wlm0 inactive
S 0.0.0.0/0 [1/0] via 10.20.2.1 inactive
C>* 10.64.64.64/32 is directly connected, ppp0
C>* 127.0.0.0/8 is directly connected, lo

  1. Further to it, I tried from unix admin added default route “route add default dev ppp0” to confirm the connection is active, by that I am able to ping via the ppp0 interface. So it seems connections got established but the naming is incorrect, it should be ‘wlm0’. Please correct me.

root@vyos:/home/vyos# route add default dev ppp0
root@vyos:/home/vyos# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=47 time=629 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=47 time=269 ms

My vyos version is

vyos@vyos:~$ show version
No hypervisor detected
Version: VyOS 999.201801111542
Built by: autobuild@vyos.net
Built on: Thu 11 Jan 2018 15:42 UTC
Build ID: d4cf560b-9641-472f-b7c4-83b039db0522

Could it be a bug?

Thanks,
Subbu


#2

Hi @subbu,
I found it fixed on upstream debian ppp package: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=458646
And I found some other issues for wirelessmodem, I’ll fix them on 1.2.0-rolling.
Thanks.


#3

Hi Yuya Kusakabe,

I tried latest rolling build VyOS 1.2.0-rolling+201805280337. But the issue is there. should I upgrade PPP separately? Or could you please suggest anyworking build.
From the message logs, it shows the ppp version as 2.4.6 “May 28 20:15:36 HYD-SDC pppd[2272]: pppd 2.4.6 started by root, uid 0”

Note: I confirmed modem up/down/rename scripts are there in /opt/vyatta/etc/ppp.

Thanks in advance,
Subbu


#4

This issue is fixed. I am planning to propose this Vyos forum, so that it can be reviewed and included in the Code.


#5