Install VyOS 1.1.7 on PC Engines APU2C4

pcengines
apu2c4

#1

I got this board several days a ago, tried to install VyOS 1.1.7 on it, and found following issues:
[list]
[]VyOS fixes the baud rate of serial port to 9600. But APU2 bios seems to only support 115200, so you can’t see boot menu or booting messages.
[
]After modifying baud rate setting in isolinux.cfg in the ISO image to get the machine displaying some messages, I found VyOS can’t detect my Transcend USB stick so the booting process just hangs. But booting with SD card works fine.
[/list]
So I’m going to share how I install VyOS on APU2 with SD card.

Download & mount VyOS iso image to a folder:

$ sudo mount -o loop vyos-1.1.7-amd64.iso /tmp/iso

Copy all content to another folder so that we can modify:

$ cp -a /tmp/iso/* /tmp/iso2

cd to /tmp/iso2, modify isolinux/isolinux.cfg to the following:

serial 0 115200 console 0 timeout 50 display boot.txt prompt 1 ...

Note you also need to set ‘console’ to ‘0’, because APU2 bios seems to redirect console messages to the serial console, which will mess up the screen.

Uncompress the root filesystem to another folder:

$ sudo unsquashfs -d /tmp/root live/filesystem.squashfs

Modify /tmp/root/opt/vyatta/sbin/vyatta-grub-setup, replace all matchings of string ‘9600’ with ‘115200’. Then regenerate the rootfs image:

$ sudo squashfs /tmp/root live/filesystem.squashfs -noappend

Finally regenerate iso image:

$ cd /tmp $ mkisofs -o vyos-out.iso -b isolinux/isolinux.bin -c isolinux/boot.cat \ -no-emul-boot -boot-load-size 4 -boot-info-table -iso-level 3 -J \ /tmp/iso2 $ isohybrid vyos-out.iso

Dump the new image to a SD card, and use it to boot machine and start installation. I installed VyOS into SSD, and after installation, I can boot from SSD and see login prompt with 115200 baud serial console.


#2

Thanks for sharing!
You can register on wiki.vyos.net and add article there,
i think it will be useful


#3

Have updated the wiki page:
https://wiki.vyos.net/wiki/Network_appliances#PC_Engines_APU2C4

The method listed in wiki is a little different from the one listed here, because I found unsquashfs doesn’t keep xattr of system binaries after extraction, which will cause problems after installation.


#4

Hi Ramax,

your information really helped me in trying to install vyos on my apu 3b4 board, thank you!

At the moment I can start the modified iso but the system allways freezes during HW detection, regardless of default or debug boot.
I tried a whole bunch of usb sticks now and my last hope is to try booting from sd card.
So what does “Dump the new image to a SD card” mean? cp the iso file to a freshly formatted SD?

Patric


#5

So I dd’ed the 1.1.7-amd.iso to sd card. Boot and install from SD card worked!

Should have tried that first; at least four usb flash drives didn’t work.
I even burned the iso to cd … didn’t work either…

Patric


#6

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.