Installation problem on PCEngines APU2C4


#1

Hello all.

First post on the forum.

I’ve been trying to install VyOS 1.1.8 on a PCEngines APU2C4, following the guide at https://wiki.vyos.net/wiki/Network_appliances#PC_Engines_APU2C4 but seem to hitting a wall.

I’ve successfully created the ISO image as laid out in the steps, confirmed the generated ISO boots by running it in a VM, written the ISO to a SDCard (even tried USB stick). I get the syslinux boot explaining to login as vyos/vyos and how to install the image. Once it passes that, I see exactly one kernel message then it appears to hang. The last message I see is “i8042: No controller found”.

Any suggestions or ideas I can try to get VyOS to boot?

Update:

Here’s the serial output from a VM to confirm it’s working:

[code]
ISOLINUX 4.02 debian-20101014 Copyright © 1994-2010 H. Peter Anvin et al


  •                                                       *
    
  • Welcome to VyOS, an open source network operating system! *
  •                                                       *
    
  • Version: 1.1.8 (Helium) *
  •                                                       *
    
  • Default login: vyos *
  • Default password: vyos *
  •                                                       *
    
  • To start installation, login and use command: *
  • install image                                         *
    
  •                                                       *
    

Press control and F then 1 for help, or ENTER to
boot:
[ 1.877635] sd 2:0:0:0: [sda] Assuming drive cache: write through
[ 1.879885] sd 2:0:0:0: [sda] Assuming drive cache: write through
[ 1.881046] sd 2:0:0:0: [sda] Assuming drive cache: write through
[ 3.722180] piix4_smbus 0000:00:07.3: Host SMBus controller not enabled!

Welcome to VyOS - vyos ttyS0

vyos login: [/code]


#2

Hi I had similar problems, it worked by burning the image to an sd card, and install vyos from there
cu peje