Interface-health nexthop dhcp very slow to update

Not sure what is happening here but maybe somebody can figure it out.
Version: VyOS 1.4-rolling-202211110728

The nexthop dhcp option of the interface-health command does not work very well for me. I have an ATT BGW320-500 gateway and a Citrix GE711 ONT providing two Internet connections to my VyOS router. When using the ‘dhcp’ option as shown below, the status of the interfaces does not show ‘active’ with ‘show wan’ for many minutes or even hours after a reboot. I had to replace the ‘dhcp’ with the actual next hop IP address to make load balancing failover work. The interfaces properly dhcp and obtain IP address, next hop etc. The interfaces work but the load balancing does not pick up the info. The ATT interface shows active within 5 minutes but he Calix interface takes up to 3 hours to show active in the ‘show wan’ command.

Long after a boot the /var/lib/dhcp/dhclient_eth1.lease file does not contain any data even well after the dhcp file, /var/lib/dhcp/dhclient_eth1.leases, is properly populated.

set load-balancing wan interface-health eth0 failure-count ‘1’
set load-balancing wan interface-health eth0 nexthop ‘dhcp’
set load-balancing wan interface-health eth0 success-count ‘1’
set load-balancing wan interface-health eth1 failure-count ‘1’
set load-balancing wan interface-health eth1 nexthop ‘dhcp’
set load-balancing wan interface-health eth1 success-count ‘1’

Wan la completely broken in 1.4 and should be rewritten ⚓ T4362 Wan Load Balancing - Can't create routing tables
It works only in LTS releases

Kinda seems to be broken in 1.3 also… WAN Load Balancing when interface stays up - General questions - VyOS Platform Community Forums

On 1.3 LB is working fine.

I can’t get it to work. Would love to. See that thread, would appreciate any ideas.

Try 1.3.x releases, it may not work in 1.4