ISIS not coming up

My ISIS neighborship will not come up. I only have a very basic setup with tunnel interfaces between 2 routers and a static route to reach between the public IPs of the routers. My isis configs is a basic one like below:

Do I have to add more config to bring up the neighborship?

protocols {
    isis {
        interface lo {
        interface tun21 {
            circuit-type level-2-only
            network {
        level level-2
        lsp-mtu 1472
        net 49.0001.2222.2222.2222.00

Is there another basic config I forgot to add… My tunnel interface is a GRE tunnel interface with basic IPaddressing config only

Are your two ISIS neighbours directly connected? It sounds like you’re trying to route ISIS between devices (multihop) ?

They would be multihop as in the eth0 interfaces are able to ping each other and the tunnel interface is connected via this public IP
I have tried connecting over the lan interface as well which was directly connected but that did not work either

Sorry - I was half asleep when I replied. It’s quite obvious you have a tunnel interface from the config you posted, please accept my apologies for the silly question.

I can’t see any reason that wouldn’t come up - you certainly seem to have all the correct commands.

What does debug output show?

Can you point me how to enable debug on vyos… I am having trouble with that as well

You probably want to enable FRR debugging as documented here.

the reason is that ISIS use layer2 frame to establish the relationship with others neighbors , tunnel gre by default is layer3 , try to use this command on both tunnels :

set interfaces tunnel tun21 encapsulation gretap

instead of encapsulation gre

I do have gretap as the encapsulation

sh interfaces tunnel tun12
 encapsulation gretap

and the peer router

sh interfaces tunnel tun21
 encapsulation gretap

Hey all I found out my tunnel interface encapsulation is not being set correctly… May be that is the problem

I have this now

sh interfaces tunnel tun12
 encapsulation gretap
 mtu 1436
 remote x.x.x.x
 source-address x.x.x.x

However, it still shows as link/ether

show  interfaces tunnel tun12
tun12@NONE: <BROADCAST,UP,LOWER_UP> mtu 1436 qdisc fq state UNKNOWN group default qlen 1000
    link/ether 4e:89:0f:50:fb:08 brd ff:ff:ff:ff:ff:ff
    inet brd scope global tun12
       valid_lft forever preferred_lft forever
    inet6 fe80::f040:4dff:fe06:e78b/64 scope link 
       valid_lft forever preferred_lft forever

    RX:  bytes  packets  errors  dropped  overrun       mcast
             0        0       0        0        0           0
    TX:  bytes  packets  errors  dropped  carrier  collisions
          3520        9       0        0        0           0

How can I fix my tunnel encapsulation please help

1 Like

Wow looks like isis is now up

sh isis neighbor 
Area VyOS:
  System Id           Interface   L  State        Holdtime SNPA
 anj-R2              tun12       2  Up            296      5aca.81be.9f64

Excellent, what was the fix in the end please? Always good to know so that when the person has this issue they can discover the answer.

My tunnel encapsulation never showed gre… but I deleted and recreated the interface and the neighborship came up
Still not sure what was wrong in the confi… May be the order I had it all configured.

1 Like

The trick is most likely than default tun is L3 while tap is L2. And since ISIS needs L2 you need tap (or other L2 capable tunneling, VXLAN would be a modern option here).

1 Like