ISIS with Cisco nexus

Hi all,

I’m having a hard time to make ISIS work with two cisco nexus. Vyos runs on a VM and the nexus are physical devices.
This is the vyos config:
set protocols isis interface eth1 circuit-type ‘level-2-only’
set protocols isis interface eth1 no-three-way-handshake
set protocols isis level ‘level-2’
set protocols isis log-adjacency-changes
set protocols isis metric-style ‘wide’
set protocols isis net ‘49.0001.0010.0255.0255.0005.00’

This is the nexus config:
router isis 1
net 49.0001.0010.0255.0255.0001.00
is-type level-2
log-adjacency-changes
address-family ipv4 unicast

Vyos shows:
vyos@vy1:~$ sh isis neighbor
Area VyOS:
System Id Interface L State Holdtime SNPA
dci5 eth1 2 Down 7 7c21.0d5e.beaf
dci1 eth1 2 Down 21 7c21.0e2e.4d67
vyos eth1 2 Up 29 4689.c92e.2387

Vyos is another vyos instance to test the isis config. dic5,dci1 are both nexus which peer on the same subnet with vyos1 and vyos2.
The MTUs seem to be fine even though I am not sure.(how can i check this?). tcdumping on the vyos-eth1 shows ISIS packets with PDU length: 8997 from both the nexus and the vyos.

I have experimented with “metric-style” and “no-three-way-handshake” with no success.

Any ideas?

Hi @spiros ,

I don’t have Nexus, but I do have an IS-IS example for Cisco IOS
VyOS side:

set interfaces ethernet eth0 address 10.0.0.1/24
set protocols isis interface eth0 circuit-type 'level-2-only'
set protocols isis level 'level-2'
set protocols isis log-adjacency-changes
set protocols isis net '49.0000.0000.0000.0000.0001.00'

Cisco IOS side:

interface Ethernet0/0
 no switchport
 ip addr 10.0.0.3 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0000.0000.0000.0000.0003.00
 is-type level-2-only

Note the need for IP addresses on the interfaces