ISO boot hangs on arm64


I successfully built a vyos 1.4 ISO file for arm64.

When I launch this ISO, it hangs after the following messages:

EFI stub: Booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services…

Standard Debian 11 ISO images boot with no issue.

I used the docker image downloaded from Docker Hub but I also built locally a new docker image with the same result.

Build environment: Debian 11 running on Parallels on a MacOS / M1

Any idea about what’s causing this freeze ?

BR, Damien.

Hi @Damien.
I have tested to build ISO image and successfully launched it. Maybe you skipping something.
Tested all VyOS 1.4 (sagitta, current).

Here is steps (ref. VyOS 1.4 (sagitta) documentation):

Installing Docker and prerequisites:

$ sudo apt-get update
$ sudo apt-get install -y apt-transport-https ca-certificates curl gnupg2 software-properties-common
$ curl -fsSL | sudo apt-key add -
$ sudo add-apt-repository “deb [arch=amd64] Index of linux/debian/ $(lsb_release -cs) stable”
$ sudo apt-get update
$ sudo apt-get install -y docker-ce

Build ISO:
Now as you are aware of the prerequisites we can continue and build our own ISO from source. For this we have to fetch the latest source code from GitHub. Please note as this will differ for both current and crux.

For VyOS 1.4 (sagitta, current)

$ git clone -b current --single-branch GitHub - vyos/vyos-build: VyOS image build scripts

Now a fresh build of the VyOS ISO can begin. Change directory to the vyos-build directory and run:

$ cd vyos-build

For VyOS 1.4 (sagitta, current)

$ docker run --rm -it --privileged -v $(pwd):/vyos -w /vyos vyos/vyos-build:current bash

For VyOS 1.4 (sagitta)

$ os=buster64 branch=sagitta make build

Start the build:

vyos_bld@8153428c7e1f:/vyos$ sudo make clean
vyos_bld@8153428c7e1f:/vyos$ sudo ./build-vyos-image iso --architecture amd64 --build-by “

When the build is successful, the resulting iso can be found inside the build directory as live-image-[architecture].hybrid.iso.

Good luck!

I also drop the link below for reference

It is 2 types of builds arm vs amd

Hi @a.hajiyev
I read you did the ISO build for amd64.
I guess there be are differences between amd64 and arm64 build processes.
I’m ok with the steps you described and I successfully get an ISO binary … it starts to boot but it hangs at some point.
BR , Damien

I have the same problem。

Same problem.

WSL2 Debian.

Tried commands

qemu-system-aarch64  -nographic -machine virt -cpu cortex-a53 -device virtio-rng-pci -smp 2 -m 1024 -bios /usr/share/qemu-efi-aarch64/QEMU_EFI.fd   -
cdrom build/live-image-arm64.hybrid.iso
qemu-system-aarch64  -nographic -machine virt -cpu cortex-a57 -device virtio-rng-pci -smp 2 -m 1024 -bios edk2-aarch64-code.fd   -cdrom build/live-image-arm64.hybrid.iso

Was anyone able to solve this issue?