ISO build missing files

Hi, I’ve followed the instructions at https://docs.vyos.io/en/latest/contributing/build-vyos.html to build a new ISO, with success. Except, that some files are missing from the final ISO (and subsequent install).
When I check the /usr/sbin dir:

vyos@vyos:~$ ls -l /usr/sbin/ | wc -l
251

Where on the rolling release:

vyos@vyos:~$ ls -l /usr/sbin/ | wc -l
400

Some of the (linked) files missing are crucial for functionality, like /usr/sbin/ip

I’m building on Debian Buster.
Am I doing something wrong in my build process or what’s happening?

1 Like

Well, depending on what branch you are building the ISO the result of your command will differ. Rolling is based on the current branch and is about ~400 files. When you build crux it will be ~240 something files.

In general this is not a valid “method” to see if it worked or not. If you build the iso and get an .iso file - all is “good” from a starters point of view. When you play arround by adding/removing packages and altering the buildsystem, we need additional information what exactly you are trying to do.

Thanks for the quick reply. I’m tried building both crux and current with the same result.
I’m not adding i any packages yet.
The reason I found this “problem” is, that when I do something simple like set an address on an interface via dhcp, it doesn’t get set. This is because /etc/dhcp/dhclient-enter-hooks.d/03-vyos-ipwrapper points to /usr/sbin/ip to set the address on the interface. But it doesn’t exist.

Please open a task on https://phabricator.vyos.net for this and report how this can be reproduced.

I’ll do that.
I just need to go through the steps, to make sure I get it right - but right now i can’t build any iso either way. It fails with
E: Unable to locate package vyos-1x-vmware
I assume something got updated. When that’s fixed I’ll post the steps to reproduce.

Rebuilt the iso today, after the vmware package came back and a build with current isn’t missing the files in /usr/sbin as before.

If I see it again, I’ll create a task on phabricator, otherwise I assume the problem has been fixed.