L2TP Bridging with vlan interface

Hola! On Mikrotik we can in define in user profile, in wich bridge we need to add user l2tp interface.

It is BCP - Bridge control protocol:

https://datatracker.ietf.org/doc/html/rfc2878

Example : If user 1 connect add him interface in bridge0.

Its really cool thing, in operator telecom solution. When Client have massive l2 mpls domain( like vpls), but 1 point of client office have located far away from normal internet connection and it have lte uplink for example. Then we up l2tp connection to Mikrotik LNS server and bridge l2tp interface with vlan interface and delivery clear l2 traffic to border routers in vpls domains.

At mikrotik routers configuration for l2tp connection user profile looks like :

/ppp profile
add bridge=br_123 name=prof_123 use-encryption=no
after what we point this ppp profile at client secret:
/ppp secret
add name=user_123 password=pass_123 profile=prof_123

In bridge configuration we have only vlan interface, l2tp interface added to a bridge dynamicly when l2tp connection is up
/interface bridge
add bridge=br_123 interface=ether1.2701

Hi @RomanTcyganov , it will be possible to implement custom scripts for l2tp VPN remote-access. A similar thing already present for PPPoE proto ⚓ T3546 Add pppoe-server CLI custom script feature

Yes, i understand, but it is feature request on future :slight_smile: