Latest rolling release has dhcp bug

vyos 1.5 rolling 202312191154 has bug the dhcp server sometimes not giving ip to some clients ,also some clients showing limited connection

The latest 1.5 build is 1.5-rolling-202312240025 as of writing - did you try that to verify if the DHCP issue have been fixed?

No joy even after updating to latest version still issue persists


Admin@vyos:~$ show dhcp server leases

WARNING: DHCP server is configured but not started. Data may be stale.

IP Address    MAC address    State    Lease start    Lease expiration    Remaining    Pool    Hostname    Origin
------------  -------------  -------  -------------  ------------------  -----------  ------  ----------  --------





show configuration commands | strip-private
set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 hw-id 'xx:xx:xx:xx:xx:ce'
set interfaces ethernet eth0 offload gro
set interfaces ethernet eth0 offload gso
set interfaces ethernet eth0 offload lro
set interfaces ethernet eth0 offload rfs
set interfaces ethernet eth0 offload rps
set interfaces ethernet eth0 offload sg
set interfaces ethernet eth0 offload tso
set interfaces ethernet eth0 ring-buffer rx '4096'
set interfaces ethernet eth0 ring-buffer tx '4096'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth1 address 'xxx.xxx.10.1/24'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 hw-id 'xx:xx:xx:xx:xx:cf'
set interfaces ethernet eth1 offload gro
set interfaces ethernet eth1 offload gso
set interfaces ethernet eth1 offload lro
set interfaces ethernet eth1 offload rfs
set interfaces ethernet eth1 offload rps
set interfaces ethernet eth1 offload sg
set interfaces ethernet eth1 offload tso
set interfaces ethernet eth1 ring-buffer rx '4096'
set interfaces ethernet eth1 ring-buffer tx '4096'
set interfaces ethernet eth1 speed 'auto'
set interfaces ethernet eth2 hw-id 'xx:xx:xx:xx:xx:d0'
set interfaces ethernet eth3 hw-id 'xx:xx:xx:xx:xx:d1'
set interfaces ethernet eth4 hw-id 'xx:xx:xx:xx:xx:d2'
set interfaces ethernet eth5 hw-id 'xx:xx:xx:xx:xx:d3'
set interfaces loopback lo
set interfaces pppoe pppoe0 authentication password xxxxxx
set interfaces pppoe pppoe0 authentication username xxxxxx
set interfaces pppoe pppoe0 ip adjust-mss 'clamp-mss-to-pmtu'
set interfaces pppoe pppoe0 source-interface 'eth0'
set nat source rule 100 source address 'xxx.xxx.10.0/24'
set nat source rule 100 translation address 'masquerade'
set service dhcp-server shared-network-name xxxxxx subnet xxx.xxx.10.0/24 default-router 'xxx.xxx.10.1'
set service dhcp-server shared-network-name xxxxxx subnet xxx.xxx.10.0/24 domain-name xxxxxx
set service dhcp-server shared-network-name xxxxxx subnet xxx.xxx.10.0/24 name-server 'xxx.xxx.10.1'
set service dhcp-server shared-network-name xxxxxx subnet xxx.xxx.10.0/24 range 0 start 'xxx.xxx.10.10'
set service dhcp-server shared-network-name xxxxxx subnet xxx.xxx.10.0/24 range 0 stop 'xxx.xxx.10.254'
set service dns forwarding allow-from 'xxx.xxx.10.0/24'
set service dns forwarding cache-size '0'
set service dns forwarding listen-address 'xxx.xxx.10.1'
set service dns forwarding name-server xxx.xxx.70.25
set service dns forwarding name-server xxx.xxx.71.25
set service ntp allow-client xxxxxx 'xxx.xxx.0.0/0'
set service ntp allow-client xxxxxx '::/0'
set service ntp server xxxxx.tld
set service ntp server xxxxx.tld
set service ntp server xxxxx.tld
set service ssh listen-address 'xxx.xxx.10.1'
set service ssh port '22'
set system config-management commit-revisions '100'
set system conntrack expect-table-size '10485760'
set system conntrack hash-size '10485760'
set system conntrack modules ftp
set system conntrack modules h323
set system conntrack modules nfs
set system conntrack modules pptp
set system conntrack modules sip
set system conntrack modules sqlnet
set system conntrack modules tftp
set system conntrack table-size '10485760'
set system console device ttyS0 speed '115200'
set system host-name xxxxxx
set system ip arp table-size '32768'
set system ip multipath layer4-hashing
set system login user xxxxxx authentication encrypted-password xxxxxx
set system login user xxxxxx authentication encrypted-password xxxxxx
set system login user xxxxxx authentication plaintext-password xxxxxx
set system name-server 'xxx.xxx.1.1'
set system syslog global facility all level 'info'
set system syslog global facility local7 level 'debug'
set system time-zone 'Asia/Dubai'

Also i made fresh install with latest rolling still problem persists

You are missing IP-address on eth0 (and eth2, eth3, eth4 and eth5).

Personally I would make sure to set “shutdown” on these otherwise ISC DHCP Server will try to utilize them (even if you didnt configure any DHCP server on them) and thats whats probably is failing in your case (since the smoketest of the nightly is passing all DHCP server tests).

So either try to configure a dummy IP-address on all (something like 127.0.100.1/24, 127.0.102.1/24 and so on should do) or better put shutdown on interfaces you wont use.

2 Likes

hello apachez i disabled all other interfaces(eth0 is pppoe so cant disable )rest interfaces which not used

set interfaces ethernet eth2 disable

and now its working ,will report back since i always never disabled before and didn’t face any issues prior
Thanks again Apachez MERRY CHRISTMAS & HAPPY NEW YEAR WISHES!!!

Hello i can confirm there is some bug in the latest rolling release related to dhcp server because i installed it also in my office labour camp with 200 users there too it randomly stops giving out dhcp leases even though i disabled unused interfaces…

Still issue persists when u create a new install its fine but upgrading breaks dhcp server ,tried in latest rolling releases :cry: why no solution???

The DHCP server migrated to KEA.
You have to add some debug info/logs to solve this issue. ⚓ T3316 Use Kea DHCP(v6) instead of ISC DHCP(v6)

2 Likes

Finally fixed in the latest rolling releases