Load config.boot error

Hello All,

I have been running Vyos 1.3.0-rc6 and had a stable site to site VPN. I made a copy of the config.boot file and reinstalled version 1.3.0 LTS. Then wanting to load my original config.boot file I ran the following command on the new install;

vyos@xxx# load https://drive.protonmail.com/urls/xxx
Loading configuration from ‘https://drive.protonmail.com/urls/xxx
Traceback (most recent call last):
File “/opt/vyatta/etc/config-migrate/migrate/config-management/0-to-1”, line 18, in
config = ConfigTree(config_file)
File “/usr/lib/python3/dist-packages/vyos/configtree.py”, line 134, in init
raise ValueError(“Failed to parse config: {0}”.format(msg))
ValueError: Failed to parse config: Syntax error on line 1, character 22: Invalid syntax.

Migration script error: /opt/vyatta/etc/config-migrate/migrate/config-management/0-to-1: Command ‘[’/opt/vyatta/etc/config-migrate/migrate/config-management/0-to-1’, ‘/tmp/tmp5450v6qh’]’ returned non-zero exit status 1…
[edit]
vyos@xxx#

Can anyone tell me why it did not load?
Thanks.

Did you try downloading the config manually to /config and loading from there?

it is also possible , Could you try with a txt. file ? in your current vm/instance (the configuration load) . does it show the same result ?

thanks

Hi madmatt,
Thanks for the suggestion, I tried it and succeeded to load the config.boot file but encountered another error when restarting Vyos which I have just been able to solve (which is also why I have taken so long to get back to you).
I appreciate the help.

1 Like

Hi Fernando,
I managed to solve the issue with madmatt’s suggestion.
Thanks for getting back to me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.