Lost "System login" information after upgrade from 1.1.7 to 1.1.8 [Solved]


#1

Hello. Strangest thing happened today. After upgrading 3 vyos 1.1.7 to 1.1.8 successfully today, I had
trouble with one of them. the only difference in all process was that I scheduled a reboot in this one to the newer version, because one lab was having classes at the time.

After booting I couldn’t login remotely. I had to local restart the machine, boot the previous version and everything is working even the remote ssh logins using the key, but the config.boot file does not contain the “login user” information and respective ssh keys are not there ?!
The problem is that if I take a backup of config.boot from now on, I’m afraid the login information won’t be there. Even if I use a previous config.boot backup and reboot, the system doesn’t show the login inforamtion.
Any ideas please?


#2

I had that issue once on a route-reflector. I just created the information in the new image. Move to 1.2. 1.1.8 has some issues and are not supported any longer as mentioned several times. I dread the upgrades but let’s face it the systems will be more updated and better.


#3

Additional information to clarify.

outside configuration mode, “show system login users” displays the current available users that somehow do not exist in /config/config.boot anymore.

Inside configuration mode, “show system” does not display any information regarding users.
?!

Tryed to add another user user plaintext password. Fails at commit “useradd: cannot lock /etc/passwd; try again later”


#4

Solved. Somehow 4 files related to password and group had a lock. Removed, rebooted, but still I had to recreate the users and respective passwords and ssh keys.
strange…


#5

That’s what I told you in my post. I had to end up creating anyway.