Multicast routing doesn't work

Hi everyone,
I have a problem with multicast routing configuration using pim. Currently, packets are being sent to the router but not forwarded. The entire environment is run in virtual machines in VMWare Workstation. eth0 is used as an interface to connect over ssh to routers. I send multicast packets using: mcjoin -s -i ens38 -t 64.
My topology is:


For now, I’m focusing on the part in the red square, I’ll deal with the next segments of the network when multicast works there.
Router configuration 1:

set firewall receive-redirects 'disable'
set firewall send-redirects 'disable'
set interfaces dummy dum0 address '192.168.255.1/24'
set interfaces ethernet eth0 address 'dhcp'
set interfaces ethernet eth0 description 'OUTSIDE'
set interfaces ethernet eth0 hw-id '00:0c:29:97:89:33'
set interfaces ethernet eth1 address '192.168.1.1/24'
set interfaces ethernet eth1 description 'SITE_01'
set interfaces ethernet eth1 hw-id '00:0c:29:97:89:3d'
set interfaces ethernet eth2 address '192.168.11.1/24'
set interfaces ethernet eth2 description 'ROUTERS'
set interfaces ethernet eth2 hw-id '00:0c:29:97:89:47'
set interfaces ethernet eth3 address '192.168.10.1/24'
set interfaces ethernet eth3 hw-id '00:0c:29:97:89:51'
set interfaces loopback lo
set nat source rule 100 outbound-interface 'eth1'
set nat source rule 100 source address '192.168.1.0/24'
set nat source rule 100 translation address 'masquerade'
set protocols igmp interface eth1
set protocols igmp interface eth2
set protocols ospf area 0 network '192.168.10.0/24'
set protocols ospf area 0 network '192.168.1.0/24'
set protocols ospf area 0 network '192.168.11.0/24'
set protocols ospf area 0 network '192.168.255.0/24'
set protocols pim interface dum0
set protocols pim interface eth1
set protocols pim interface eth2
set protocols pim interface eth3
set protocols pim rp address 192.168.255.1 group '224.0.0.0/4'
set protocols rip

Router configuration 2:

set firewall receive-redirects 'disable'
set firewall send-redirects 'disable'
set interfaces ethernet eth0 address 'dhcp'
set interfaces ethernet eth0 description 'OUTSIDE'
set interfaces ethernet eth0 hw-id '00:0c:29:8e:af:ab'
set interfaces ethernet eth1 address '192.168.2.1/24'
set interfaces ethernet eth1 description 'SITE_02'
set interfaces ethernet eth1 hw-id '00:0c:29:8e:af:b5'
set interfaces ethernet eth2 address '192.168.11.2/24'
set interfaces ethernet eth2 description 'ROUTERS'
set interfaces ethernet eth2 hw-id '00:0c:29:8e:af:bf'
set interfaces ethernet eth3 address '192.168.12.1/24'
set interfaces ethernet eth3 hw-id '00:0c:29:8e:af:c9'
set interfaces loopback lo
set protocols igmp interface eth1
set protocols igmp interface eth2
set protocols ospf area 0 network '192.168.2.0/24'
set protocols ospf area 0 network '192.168.11.0/24'
set protocols ospf area 0 network '192.168.12.0/24'
set protocols pim interface eth2
set protocols pim interface eth3
set protocols pim rp address 192.168.255.1 group '224.0.0.0/4'
set protocols rip
set protocols static

Are you sure this isn’t a problem/issue with VMWare filtering your multicast traffic?
I can’t find the link to it now, but I’m sure I’ve read of this problem before and it was VMWare filtering the multicast.
(To be clear I’m not saying it is VMWare, only that I have a vague recall of a similar issue and it turned out VMWare networking stack was the cause)

I’m almost 100% sure :sweat_smile: using command monitor traffic eth1 I can see incoming data packets on eth1 interface, when using the same command for eth2, there are no outgoing data packets, it looks like communication between router 1 and router 2 is not working properly.

NOTE: Between the routers I can see PIM Hello packets, which are multicast packets

Hi @Drock , which multicast group address are you using? I know that some multicast group from 224.x.x.x/24 already reserved and traffic will not pass.

I use the group 224.0.20.10

Did you try to get diagnostic output?

show ip pim upstream
show ip pim state
show ip igmp groups