No-IP DDNS autoupdate

ddns
no-ipcom
vyos-1-2

#1

Hello there,

I set to No-IP DDNS, it working well, but the website say that is not sync…

I set it yesterday, but today i restart my VyOS, but the ddns not update automatically… (i wait about half and hour)

it is normal? How many time to sync it?


#2

Hi,
which version of VyOS.
show relevant part of config please


#3
Version:          VyOS 1.2.0-rolling+201804110337
Built by:         autobuild@vyos.net
Built on:         Wed 11 Apr 2018 03:37 UTC
Build ID:         a7cf1949-4659-43e8-82ca-1db806310d4b

Architecture:     x86_64
Boot via:         installed image
System type:      KVM guest

Hardware vendor:  QEMU
Hardware model:   Standard PC (i440FX + PIIX, 1996)
Hardware S/N:
Hardware UUID:    5EC01258-023E-4D67-9549-5B942B664D26

Copyright:        VyOS maintainers and contributors

config

   dns {
        dynamic {
            interface eth0 {
                service noip {
                    host-name *****.ddns.net
                    login *********
                    password ****************
                }
            }
        }

Edit:

Ahhh it possible that i found the problem :slight_smile:
I use PPPOE, but set to eth0 to source interface, instead of pppoe 1…

What do you think?


#4

I think i would like to know if it work on pppoe :slight_smile:
also if it works after reboot (suspect that it can be issue if pppoe shows up later)


#5

Working, thanks! :slight_smile:


#8

By any chance you want do quick guide with screenshots ?


#9

Thats all:

# edit service dns dynamic interface pppoe 1 service noip
# set login my-login
# set password my-password
# set host-name my-dyndns-hostname

#10

i mean screenshots from no-ip :slight_smile:


#11

i do nothing in no-ip site. That is all i can see:


#12

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.