NTP not syncing with dummy interface

Running version: VyOS 1.4-rolling-202206300217

If I bind the NTP server to a dummy interface, I cannot get NTP client (ubuntu 22.04) to sync.

nmap -sU -p 123 <<DUMMY_HOST_IP>> shows the port is open, but sync state remains ‘unsynced’.

I tried on VyOS 1.4-rolling-202207030217 as a server. Debian 11 and Windows 10 as clients. And it works.

Server config:

set interfaces dummy dum1 address ''
set system ntp allow-clients address ''
set system ntp listen-address ''
set system ntp server pool.ntp.org

Still having this issue; you are correct that I can sync with the dummy interface; but only as long as I also bind the NTP to a ‘real’ interface as well. If I remove all binds to ‘real’ interfaces and only set listen-address to the dummy interface, NTP is not syncing…

Do you have snat rules to allow ip address on dummy interface to communicate with external ntp servers?

Don’t know how I missed that… Thanks; looks like it’s solved, misconfig on my side! TY!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.