NTP not syncing with peers in VyOs Rolling


I have recently discovered VyOS and been testing with the rolling release. I have it running on my bare metal home router as well as in a VM lab at work. For some reason NTP does not sync to any peers on either. I have tried different rolling release versions and none of them have worked. Out of curiosity, I did a build of crux via Docker and installed the image; NTP synced right away without issues. Is there something new I’m missing with the rolling release that requires extra steps for ntpd to sync as a client to peers?

Thank you

Can you check if you have in /etc/ntp.conf the line interface ignore wildcard. If so, put it into comment and restart ntpd and check if it works then.

@hagbard thank you for the reply. Your insight seems to be spot on. I commented out interface ignore wildcard in /etc/ntp.conf and then restarted ntpd. NTP is now able to peer with configured ntp servers. Does this translate into a VyOS configuration command of some sort?

Interestingly, using set system ntp listen-address x.x.x.x to the IP of the “WAN” interface also allows NTP to sync to the configured ntp servers (using the default in VyOS). However, it did not work setting the ntp listen-address to the IP of my “LAN” or “dummy” interface.

1 Like

That should probably go into the documentation. You must have a ntp listen-address in your config for NTP to work. This is somewhat counter-intuitive, I admit, but is also the only secure way to use NTP, unfortunately.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.