OSPF behavior on VRRP groups (solved)

ospf

#1

Hello.
I have ospf area showed on pic.


A, B, C - vyos, D - edgeos.
Digits - ip ospf cost on interfaces.
Master, backup - vrrp roles.
I expect that ospf creates route to CD-network through C, but on A I see route to CD-network through D.
What I have missed?
Let me know if need additional info for explaining.
Thanks.


#4

Hi,

Could you provide output from router A:
show ip ospf interface
show ip ospf database

Oleksandr Mamenko


#5

show ip ospf interface

eth0 is up
  ifindex 2, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  OSPF not enabled on this interface
eth1 is up
  ifindex 3, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  OSPF not enabled on this interface
eth2 is down
  ifindex 4, MTU 1500 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
eth3 is down
  ifindex 5, MTU 1500 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
eth4 is down
  ifindex 6, MTU 1500 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
eth5 is down
  ifindex 7, MTU 1500 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
eth6 is up
  ifindex 8, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  OSPF not enabled on this interface
eth7 is down
  ifindex 9, MTU 1500 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
eth8 is up
  ifindex 10, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  OSPF not enabled on this interface
eth9 is down
  ifindex 11, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,MULTICAST>
  OSPF not enabled on this interface
gre0 is down
  ifindex 12, MTU 1476 bytes, BW 0 Kbit <NOARP>
  OSPF not enabled on this interface
gretap0 is down
  ifindex 13, MTU 1476 bytes, BW 0 Kbit <BROADCAST,MULTICAST>
  OSPF not enabled on this interface
lo is up
  ifindex 1, MTU 65536 bytes, BW 0 Kbit <UP,LOOPBACK,RUNNING>
  OSPF not enabled on this interface
tun0 is up
  ifindex 15, MTU 1476 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP>
  OSPF not enabled on this interface
tun4 is up
  ifindex 155843, MTU 1476 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP>
  OSPF not enabled on this interface
tun100 is down
  ifindex 0, MTU 1472 bytes, BW 0 Kbit <ALLMULTI,MULTICAST>
  OSPF not enabled on this interface
vtun1 is up
  ifindex 210681, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.185/32, Peer 172.16.1.186, Area 0.0.0.3
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun2 is down
  ifindex 0, MTU 1500 bytes, BW 0 Kbit <POINTOPOINT,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun3 is up
  ifindex 231880, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.169/32, Peer 172.16.1.170, Area 0.0.0.7
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 4.611s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun4 is up
  ifindex 212090, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.173/32, Peer 172.16.1.174, Area 0.0.0.2
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 10
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun5 is up
  ifindex 210672, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.177/32, Peer 172.16.1.178, Area 0.0.0.2
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun7 is up
  ifindex 216229, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun8 is up
  ifindex 231310, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.1/32, Peer 172.16.1.2, Area 0.0.0.4
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 10
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 4.534s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun9 is up
  ifindex 228153, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.5/32, Peer 172.16.1.6, Area 0.0.0.4
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 8.039s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun10 is up
  ifindex 210688, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun16 is up
  ifindex 213618, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.33/32, Peer 172.16.1.34, Area 0.0.0.11
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun17 is up
  ifindex 232267, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.37/32, Peer 172.16.1.38, Area 0.0.0.5
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 10
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.547s
  Neighbor Count is 0, Adjacent neighbor count is 0
vtun18 is down
  ifindex 0, MTU 1500 bytes, BW 0 Kbit <POINTOPOINT,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun19 is up
  ifindex 210678, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.45/32, Peer 172.16.1.46, Area 0.0.0.10
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun21 is up
  ifindex 210685, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.57/32, Peer 172.16.1.58, Area 0.0.0.5
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun25 is up
  ifindex 232268, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun27 is up
  ifindex 210683, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  OSPF not enabled on this interface
vtun31 is up
  ifindex 210682, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.113/32, Peer 172.16.1.114, Area 0.0.0.6
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 5
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.147s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun40 is up
  ifindex 231884, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  Internet Address 172.16.1.193/32, Peer 172.16.1.194, Area 0.0.0.7
  MTU mismatch detection:enabled
  Router ID 1.1.1.1, Network Type POINTOPOINT, Cost: 10
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 7.751s
  Neighbor Count is 1, Adjacent neighbor count is 1
vtun43 is up
  ifindex 229371, MTU 1500 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>
  OSPF not enabled on this interface 

show ip ospf database

   OSPF Router with ID (1.1.1.1)

            Router Link States (Area 0.0.0.0)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1          682 0x8000045a 0x7a81 0

            Router Link States (Area 0.0.0.2)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1         1042 0x80000469 0x398a 4
1.1.1.2         1.1.1.2         1174 0x80000467 0x1ead 4
1.1.1.8         1.1.1.8          583 0x80000377 0x2a7a 4
1.1.1.9         1.1.1.9         1788 0x800001d4 0x1a15 4

            Router Link States (Area 0.0.0.3)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1           32 0x800004d8 0xdf7e 2
1.1.1.2         1.1.1.2           54 0x8000049c 0x0968 2
1.1.1.4         1.1.1.4           91 0x8000051b 0xdeea 4

            Router Link States (Area 0.0.0.4)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1          952 0x8000046b 0x8ce7 4
1.1.1.2         1.1.1.2          584 0x80000459 0x1f74 4
1.1.1.5         1.1.1.5          292 0x8000045b 0xed34 4
1.1.1.12        1.1.1.12        1042 0x80000465 0xeafe 4

            Router Link States (Area 0.0.0.5)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1           22 0x80004a72 0x8ce9 3
1.1.1.2         1.1.1.2           28 0x80004a70 0x9a5e 3
1.1.1.15        1.1.1.15         453 0x80000158 0x9208 4

            Router Link States (Area 0.0.0.6)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1         1642 0x800082b2 0x9af9 2
1.1.1.2         1.1.1.2         1344 0x80008502 0x05dc 3
1.1.1.6         1.1.1.6         1612 0x800004e5 0xf53e 4

            Router Link States (Area 0.0.0.7)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1         1002 0x80000552 0x8438 4
1.1.1.2         1.1.1.2          344 0x8000197e 0xfac8 2
1.1.1.8         1.1.1.8          221 0x80000073 0xde07 4
1.1.1.14        1.1.1.14           5 0x8000008d 0xe084 2

            Router Link States (Area 0.0.0.10)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1         1742 0x8000014f 0x7e7e 2
1.1.1.2         1.1.1.2          324 0x80000150 0x3cdc 2
1.1.1.11        1.1.1.11         821 0x80000153 0x03da 4

            Router Link States (Area 0.0.0.11)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
1.1.1.1         1.1.1.1          282 0x8000016c 0xc42e 2
1.1.1.2         1.1.1.2           64 0x8000016f 0x6636 2
1.1.1.16        1.1.1.16        1033 0x80000167 0x5728 4

            AS External Link States

Link ID         ADV Router      Age  Seq#       CkSum  Route
10.0.0.0        1.1.1.1          202 0x8000050d 0xe3bb E2 10.0.0.0/8 [0x0]
10.0.0.0        1.1.1.2           94 0x800004e0 0x3992 E2 10.0.0.0/8 [0x0]
10.0.0.0        10.10.29.3      3600 0x80000006 0x96e4 E2 10.0.0.0/8 [0x0]
192.168.3.0     1.1.1.1         1842 0x8000050f 0x8fab E2 192.168.3.0/24 [0x0]
192.168.3.0     1.1.1.2          164 0x800004df 0xea7f E2 192.168.3.0/24 [0x0]
192.168.3.0     1.1.1.5         3600 0x80000053 0xfdf9 E2 192.168.3.0/24 [0x0]
192.168.3.0     10.10.29.3      3600 0x80000006 0x46d2 E2 192.168.3.0/24 [0x0]
192.168.4.0     1.1.1.14        1580 0x80000016 0x55b5 E2 192.168.4.0/24 [0x0]
192.168.7.0     1.1.1.3          123 0x80000423 0x32ef E2 192.168.7.0/24 [0x0]
192.168.7.0     1.1.1.13         183 0x8000091e 0xf027 E2 192.168.7.0/24 [0x0]
192.168.19.0    1.1.1.8         1375 0x80003c5a 0x96ea E2 192.168.19.0/24 [0x0]
192.168.19.0    1.1.1.9          317 0x800001b8 0x85d7 E2 192.168.19.0/24 [0x0]
192.168.22.0    1.1.1.5          122 0x80000928 0x62a5 E2 192.168.22.0/23 [0x0]
192.168.22.0    1.1.1.12          62 0x8000091f 0x4abf E2 192.168.22.0/23 [0x0]
192.168.24.0    1.1.1.4           31 0x8000066f 0xccf5 E2 192.168.24.0/23 [0x0]
192.168.36.0    1.1.1.16        1363 0x80000152 0x5d51 E2 192.168.36.0/22 [0x0]
192.168.40.0    1.1.1.15         745 0x80000155 0x13b5 E2 192.168.40.0/22 [0x0]
192.168.44.0    1.1.1.6          832 0x80000458 0x0eb9 E2 192.168.44.0/22 [0x0]
192.168.48.0    1.1.1.11         551 0x80000151 0xf8af E2 192.168.48.0/22 [0x0]

Described area - 7.


#6

So, VyOS “A” has next interfaces:
vtun3 - to VyOS “C” area 7, cost 5
vtun40 - to router “D” area 7, cost 5

Is interface for CD-network in area 7? And what network is it?
Also, provide output for next commands on “A”:
show ip ospf neighbor
show ip route ospf


#7

vtun40 - to router D area 7 - yes, but cost 10, not 5.

What interface do you mean?

from A
show protocols ospf area 7

network 172.16.1.168/30
network 172.16.1.192/30

show ip ospf neighbor

    Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
1.1.1.6           1 Full/DROther      30.757s 172.16.1.114    vtun31:172.16.1.113      0     0     0
1.1.1.15          1 Full/DROther      39.604s 172.16.1.58     vtun21:172.16.1.57       0     0     0
1.1.1.11          1 Full/DROther      33.519s 172.16.1.46     vtun19:172.16.1.45       0     0     0
1.1.1.4           1 Full/DROther      36.599s 172.16.1.186    vtun1:172.16.1.185       0     0     0
1.1.1.8           1 Full/DROther      39.530s 172.16.1.178    vtun5:172.16.1.177       0     0     0
1.1.1.9           1 Full/DROther      36.164s 172.16.1.174    vtun4:172.16.1.173       0     0     0
1.1.1.16          1 Full/DROther      35.813s 172.16.1.34     vtun16:172.16.1.33       0     0     0
1.1.1.5           1 Full/DROther      30.929s 172.16.1.6      vtun9:172.16.1.5         0     0     0
1.1.1.12          1 Full/DROther      30.965s 172.16.1.2      vtun8:172.16.1.1         0     0     0
1.1.1.8          10 Full/DROther      33.049s 172.16.1.170    vtun3:172.16.1.169       0     0     0
1.1.1.14         10 Full/DROther      36.798s 172.16.1.194    vtun40:172.16.1.193      0     0     0

show ip route ospf

O   10.0.0.0/8 [110/20] via 172.16.1.34, 1d16h20m
O   172.16.1.2/32 [110/10] is directly connected, vtun8, 1d03h26m
O   172.16.1.6/32 [110/5] is directly connected, vtun9, 2d03h46m
O   172.16.1.34/32 [110/5] is directly connected, vtun16, 6d22h29m
O   172.16.1.38/32 [110/10] is directly connected, vtun17, 00:00:37
O   172.16.1.46/32 [110/5] is directly connected, vtun19, 01w0d19h
O>* 172.16.1.53/32 [110/15] via 172.16.1.6, vtun9, 2d03h46m
O>* 172.16.1.54/32 [110/20] via 172.16.1.6, vtun9, 2d03h46m
O   172.16.1.58/32 [110/5] is directly connected, vtun21, 01w0d23h
O>* 172.16.1.73/32 [110/20] via 172.16.1.2, vtun8, 1d03h26m
O>* 172.16.1.74/32 [110/25] via 172.16.1.6, vtun9, 2d03h46m
O>* 172.16.1.77/32 [110/15] via 172.16.1.186, vtun1, 00:18:01
O>* 172.16.1.78/32 [110/20] via 172.16.1.186, vtun1, 00:18:01
O   172.16.1.114/32 [110/5] is directly connected, vtun31, 01w1d01h
O>* 172.16.1.118/32 [110/25] via 172.16.1.114, vtun31, 2d20h35m
O>* 172.16.1.121/32 [110/15] via 172.16.1.114, vtun31, 01w1d01h
O>* 172.16.1.122/32 [110/20] via 172.16.1.114, vtun31, 01w1d01h
O>* 172.16.1.154/32 [110/25] via 172.16.1.58, vtun21, 00:00:37
O>* 172.16.1.158/32 [110/15] via 172.16.1.46, vtun19, 01w0d19h
O>* 172.16.1.161/32 [110/15] via 172.16.1.170, vtun3, 21:57:25
O>* 172.16.1.162/32 [110/25] via 172.16.1.170, vtun3, 20:44:30
O>* 172.16.1.166/32 [110/15] via 172.16.1.178, vtun5, 01w0d16h
O   172.16.1.170/32 [110/5] is directly connected, vtun3, 21:57:25
O   172.16.1.174/32 [110/10] is directly connected, vtun4, 01w0d11h
O   172.16.1.178/32 [110/5] is directly connected, vtun5, 01w0d16h
O>* 172.16.1.182/32 [110/20] via 172.16.1.174, vtun4, 1d14h32m
O   172.16.1.186/32 [110/5] is directly connected, vtun1, 01w0d17h
O>* 172.16.1.189/32 [110/15] via 172.16.1.58, vtun21, 01w0d22h
O>* 172.16.1.190/32 [110/20] via 172.16.1.58, vtun21, 01w0d21h
O   172.16.1.194/32 [110/10] is directly connected, vtun40, 23:12:55
O>* 172.16.1.202/32 [110/15] via 172.16.1.34, vtun16, 1d16h20m
O   192.168.3.0/24 [110/20] via 172.16.1.34, 1d16h20m
O   192.168.4.0/24 [110/20] via 172.16.1.194, 00:07:02
O   192.168.19.0/24 [110/20] via 172.16.1.170, 00:16:58
O>* 192.168.22.0/23 [110/20] via 172.16.1.6, vtun9, 2d03h45m
O>* 192.168.24.0/23 [110/20] via 172.16.1.186, vtun1, 00:18:00
O>* 192.168.36.0/22 [110/20] via 172.16.1.34, vtun16, 1d16h20m
O>* 192.168.40.0/22 [110/20] via 172.16.1.58, vtun21, 01w0d22h
O>* 192.168.44.0/22 [110/20] via 172.16.1.114, vtun31, 01w1d01h
O>* 192.168.48.0/22 [110/20] via 172.16.1.46, vtun19, 01w0d19h

#8

Hope this diagram will help
What is CD network? I mean subnet like 192.168.4.0/24.
Are you redistributing it or it is in the same area?
In case of redistribution run on A:
sh ip ospf database external adv-router 1.1.1.8 / 1.1.1.14
In case CD-network interfaces are in area7 run on A:
sh ip ospf database router adv-router 1.1.1.8 / 1.1.1.14


#9

Yes, CD-network is 192.168.4.0/24.
It is not in the same area, i redistribute this network with

protocols ospf redistribute connected

on C and D.

run show ip ospf database external adv-router 1.1.1.8

   OSPF Router with ID (1.1.1.1)

            AS External Link States

LS age: 632
Options: 0x22 : *|-|DC|-|-|-|E|*
LS Flags: 0x6
LS Type: AS-external-LSA
Link State ID: 192.168.19.0 (External Network Number)
Advertising Router: 1.1.1.8
LS Seq Number: 800065ca
Checksum: 0x3aad
Length: 36
Network Mask: /24
    Metric Type: 2 (Larger than any link state path)
    TOS: 0
    Metric: 20
    Forward Address: 0.0.0.0
    External Route Tag: 0

Network 192.168.19.0 is redistributed in area 2, not 7. Don’t understand why it appears here.

run show ip ospf database external adv-router 1.1.1.14

   OSPF Router with ID (1.1.1.1)

            AS External Link States

LS age: 837
Options: 0x22 : *|-|DC|-|-|-|E|*
LS Flags: 0x6
LS Type: AS-external-LSA
Link State ID: 192.168.4.0 (External Network Number)
Advertising Router: 1.1.1.14
LS Seq Number: 8000012b
Checksum: 0x28cc
Length: 36
Network Mask: /24
    Metric Type: 2 (Larger than any link state path)
    TOS: 0
    Metric: 20
    Forward Address: 0.0.0.0
    External Route Tag: 0

#10

From your output, 1.1.1.8 is not sending LSA for 192.168.4.0/24 network - that is a problem.
For next steps, please provide from 1.1.18:
vyos@vyos:~$ show ip route connected
vyos@vyos:~$ show int
vyos@vyos# show | commands | grep -E “ospf|policy”


#11

run show ip route connected

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
   I - ISIS, B - BGP, > - selected route, * - FIB route

C>* xx.xx.xx.xx/24 is directly connected, eth1
C>* 127.0.0.0/8 is directly connected, lo
C>* 172.16.1.161/32 is directly connected, vtun37
C>* 172.16.1.169/32 is directly connected, vtun3
C>* 192.168.4.0/24 is directly connected, eth0

xx.xx.xx.xx - external ip.

run show interfaces

Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
eth0             192.168.4.3/24                    u/u  lan
                 192.168.4.1/24
eth1             xx.xx.xx.xx/24                    u/u  provider
eth2             -                                 u/D
lo               127.0.0.1/8                       u/u
                 ::1/128
vtun3            172.16.1.170                      u/u  2A
vtun37           172.16.1.162                      u/u  2B

show | commands | grep -E “ospf|policy”

set firewall state-policy established action 'accept'
set firewall state-policy invalid action 'drop'
set firewall state-policy related action 'accept'
set interfaces openvpn vtun3 ip ospf cost '5'
set interfaces openvpn vtun3 ip ospf dead-interval '40'
set interfaces openvpn vtun3 ip ospf hello-interval '10'
set interfaces openvpn vtun3 ip ospf priority '10'
set interfaces openvpn vtun3 ip ospf retransmit-interval '5'
set interfaces openvpn vtun3 ip ospf transmit-delay '1'
set interfaces openvpn vtun37 ip ospf cost '10'
set interfaces openvpn vtun37 ip ospf dead-interval '40'
set interfaces openvpn vtun37 ip ospf hello-interval '10'
set interfaces openvpn vtun37 ip ospf priority '5'
set interfaces openvpn vtun37 ip ospf retransmit-interval '5'
set interfaces openvpn vtun37 ip ospf transmit-delay '1'
set policy prefix-list lan-networks rule 2 action 'permit'
set policy prefix-list lan-networks rule 2 description 'allow to redistribute lan networks'
set policy prefix-list lan-networks rule 2 le '32'
set policy prefix-list lan-networks rule 2 prefix '192.168.4.0/24'
set policy route-map lan-networks rule 1 action 'permit'
set policy route-map lan-networks rule 1 match ip address prefix-list 'lan-networks'
set policy route-map lan-networks rule 11 action 'deny'
set protocols ospf area 7 network '172.16.1.168/30'
set protocols ospf area 7 network '172.16.1.160/30'
set protocols ospf parameters abr-type 'cisco'
set protocols ospf parameters router-id '1.1.1.8'
set protocols ospf redistribute connected metric-type '2'
set protocols ospf redistribute connected route-map 'lan-networks'

#12

I noticed that

show ip ospf neighbour

shows two similar router-ids

If I change router-id on edgeos, I can do

clear ip ospf prosess

Vyos remembers all previous own router-ids and areas.
Reboot destroys fantom areas and router-ids…


#13

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.