Podman 4.9.5 requires unsatisfiable dependency

It appears that Trixie’s podman has been rev’d from 4.9.4+ds1-1 to 4.9.5+ds1-1 and with this, a dependency on libc6 >= 2.38, but Bookworm only provides 2.36-9+deb12u7. This yields a failure to build the iso. This impacts Current, Circinus, and Sagitta builds.

Fortunately, this is also confirmed with the nightly build:

This is worked around in vyos-build PR #690, container: T5867: pin specific podman version #690

1 Like