PPPoE client with connect-on-demand and ipv6 enable

I am trying pppoe client mode under vyos 1.3 rolling.
As minimum config I set following configuration for pppoe1

‘set interface pppoe pppoe1 connect-on-demand’
‘set interface pppoe pppoe1 ipv6 enable’
‘set interface pppoe pppoe1 source-interface eth0’

when I do commit, there is no complaint. But pppd does not start.

When I tried to start it manually using command
‘sudo pppd call pppoe1’

pppd complains as
“pppd: local/remote LL address required for demand-dialling”

I verified the configuration file as this do input option
‘ipv6cp-use-ipaddr’
but still pppd do not start

Anyone have any idea, to resolve this ??
I can manually put local and remote address in the configuration file by
ipv6 ::dead:beef,::dead:beef
but I don`t want to use this option as I will have to generate mac address/s each time.

Please, help me if anyone has different idea to solve this.
Thank you

Hi,

I am using PPPoE client with IPv6 with my ISP - Andrews and Arnold. I have documented my setup here:
https://support.aa.net.uk/Router_-_VyOS

Although I really need to update it with the work I did on setting up the firewall.

Why do you want the connect-on-demand option?
Typically that is only used for dial-up modems, where you want to minimise the amount of time the phone line is in use. I am not really sure why that would be useful with PPPoE?

nick.

In my case I do need that dial-on-demand option for dial-up modems. Because I am also using pppoe for IPv4 as well.