PPPoE Server Session Control

Hi Everyone,

The session control option in the PPPoE server on 1.3 latest rolling release is malfunctioning where deny session on PPPoE is not working. Whatever be the configuration the default value of disable is considered.

To overcome this the template file pppoe.config.tmpl under accel-ppp folder has to be updated as below.

Error noticed:-

  1. Session control variable should be under [common] group in PPPoE configuration file but the auto phyton script is creating the session control variable under [ppp] group.

  2. The configuration variable mismatch resulting in default session control replace value with whatever configuration loaded in vyos.

Update Script:-

Add the below lines after [core] module.

[common]
{% if not session_control == ‘disable’ %}
{% if session_control %}
single-session={{session_control}}
{% else %}
single-session={{sesscrtl}}
{% endif -%}
{% endif %}

Post Update:-

Session control now works for all three cases. Deny, replace and disable.

Thank You.

Hi @chinraam, yes this was migrated in the PPPoE daemon. Thanks.
Default behavior defined as replace. So you can only choice disable or deny, if you don’t set this, it will replace
I already created bug report on https://phabricator.vyos.net/T2391

Thank You @Dmitry

Hello @chinraam, already fixed on the latest rollings.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.