Problem setting gateway-address on Vyos

Hi Everyone, I am trying to deploy VYOS in my lab and running into issues with the configuring the gateway for eth0. I get error "Configuration path: system [gateway-address] is not valid. This is directly from the document. Am i using the wrong document?
12%20AM

Default gateway

Set a default gateway address for the system:

set system gateway-address

guide- https://wiki.vyos.net/wiki/System_management#Default_gateway
OVA- https://marketplace.vmware.com/vsx/solutions/vyos-1-2-lts-1-2-0
Thanks,

I never use system gateway , try adding static route:
set protocols static route 0.0.0.0/0 next-hop 10.159.18.1

VYOS Version
00%20AM

system gateway has been replaced with ‘set protocols static route 0.0.0.0/0 next-hop X.X.X.X’.
https://vyos.readthedocs.io/en/latest/routing.html

Thanks, This solved my problem…

I am running into another issue, cant ping the devices on different network.

Foreman Server (PXE, IMAGING server)

  • Configured with Single Interface 10.158.18.168/24
  • Discovery setup
  • Setup with DHCP for 10.20.20.0/24

Vyos:
Eth0 - 10.158.18.254/24 - Outbound
Eth1 - 10.20.20.254/24 - DHCP- Relay
Eth2 - 172.16.17.1/24 - DHCP Server

Problem:
Eth1 - 10.20.20.0/24, devices in this network not getting IP address from Foreman
Eth2 - 172.16.17.0/24 - Devices In this network pickup DHCP address and can access internet.
– ping 8.8.8.8 no problem
– ping 10.158.18.254 no problem
– ping 10.158.18.168 fails…

Here is my config:

interfaces {
ethernet eth0 {
address 10.159.18.254/24
hw-id 00:50:56:87:93:45
}
ethernet eth1 {
address 10.20.20.254/24
hw-id 00:50:56:87:0d:ce
}
ethernet eth2 {
address 172.16.17.1/24
}
loopback lo {
}
}
protocols {
static {
route 0.0.0.0/0 {
next-hop 10.159.18.1 {
}
next-hop 10.159.18.254 {
distance 1
}
}
route 10.159.18.0/24 {
next-hop 10.159.18.254 {
distance 2
}
}
}
}
service {
dhcp-relay {
interface eth0
interface eth1
relay-options {
relay-agents-packets discard
}
server 10.159.18.168
}
dhcp-server {
shared-network-name dhcpexample {
authoritative
subnet 172.16.17.0/24 {
default-router 172.16.17.1
dns-server 172.16.17.1
lease 86400
range 0 {
start 172.16.17.100
stop 172.16.17.199
}
}
}
}

Have you checked that if the traffic is getting to the destination. Could be that your destination isn’t routing it back.

I solved the issue, I added some nat rules and that allowed me to communicated…

Remaining issue is DHCP relay. I will check make sure DHCP options are properly configured…