Problem with OSPF over GRE tunnel with 1.3 and 1.4

Hi,
i’m doing some test to use OSPF over a gre tunnel, same configuration work well with VYOS 1.2.x.

I tried with 1.3-rolling and 1.4-rolling but it doesn’t work like on 1.2…

vyos@VYOS13-no:~$ sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
10.255.255.2 1 Init/DROther 38.638s 10.0.6.1 tun0:10.0.6.2 0 0 0

I tested the same scenario terminating the tunnels on a cisco and a mikrotik, without success.

PCAP screenshot

Some idea?
I tried to change mtu, ospf parameters and network type on both end… nothing changed…
Thanks a lot :slight_smile:

— my config —
set interfaces ethernet eth0 address ‘10.0.3.3/24’
set interfaces loopback lo
set interfaces tunnel tun0 address ‘10.0.6.2/30’
set interfaces tunnel tun0 encapsulation ‘gre’
set interfaces tunnel tun0 ip ospf dead-interval ‘40’
set interfaces tunnel tun0 ip ospf hello-interval ‘10’
set interfaces tunnel tun0 ip ospf network ‘point-to-point’
set interfaces tunnel tun0 ip ospf priority ‘1’
set interfaces tunnel tun0 ip ospf retransmit-interval ‘5’
set interfaces tunnel tun0 ip ospf transmit-delay ‘1’
set interfaces tunnel tun0 local-ip ‘10.0.3.3’
set interfaces tunnel tun0 remote-ip ‘10.0.1.2’
set protocols ospf area 3 network ‘10.0.6.0/24’
set protocols ospf area 3 network ‘10.0.7.0/24’
set protocols static route 0.0.0.0/0 next-hop 10.0.3.1
set protocols static route 10.0.1.2/32 next-hop 10.0.3.1
set protocols static route 10.255.255.2/32 next-hop 10.0.3.1

Hello @ig0rb , as you know OSPF uses a multicast group address, so in 1.3/1.4 by default ttl=1 for tunnels. Try to change TTL

set interfaces tunnel tun0 parameters ip ttl 16

Also VyOS from 1.4 have a bit different syntax for some options

set protocols ospf area 3 network '10.0.6.0/24'
set protocols ospf area 3 network '10.0.7.0/24'
set protocols ospf interface tun0 dead-interval '40'
set protocols ospf interface tun0 hello-interval '10'
set protocols ospf interface tun0 network 'point-to-point'
set protocols ospf interface tun0 priority '1'
set protocols ospf interface tun0 retransmit-interval '5'
set protocols ospf interface tun0 transmit-delay '1'

Hi,
it works thanks a lot :slight_smile: