QoS - destination IP pools

WAN - eth0
LAN -eth1 > PPPoE0 > User > rate-limit 2048/1024

Now, I want all PPPoE users bypass rate-limit for selected destination IP Pools by using bandwidth of 10mbit per user.

Below is the configuration set: (Which is not working for selected destination IP Pools)

firewall {
group {
network-group PEERING-LIST {
network 173.194.0.0/16
network 74.125.0.0/16
network 202.177.244.0/24
network 124.155.0.0/16

policy {
route PEERING-LIST {
rule 100 {
destination {
group {
network-group PEERING-LIST
}
}
set {
mark 200

traffic-policy {
shaper PEERING {
bandwidth 10mbit
class 14 {
match PEERING-LIST {
mark 200
}
}
default {
bandwidth 10mbit
queue-type fair-queue

interfaces {
ethernet eth1 {
duplex auto
hw-id 00:25:90:37:41:1d
policy {
}
pppoe 0 {
default-route auto
mtu 1492
name-server auto
traffic-policy {
out PEERING

Hello @mahendra

Can you please share the configurations of both PPPoE client and server?

Please use

show configuration commands

Cheers

Hi,

Below is the configuration:

| Welcome to VyOS
Linux SLBB-NAS-TEST 4.19.89-amd64-vyos #1 SMP Fri Dec 20 15:24:48 UTC 2019 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Jan 14 18:29:49 2020 from

???@SLBB-NAS-TEST:~$ show configuration

firewall {
all-ping enable
broadcast-ping disable
config-trap disable
group {
network-group PEERING-LIST {
network 173.194.0.0/16
network 74.125.0.0/16
network 216.58.0.0/16
}
}
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
receive-redirects disable
send-redirects enable
source-validation disable
syn-cookies enable
twa-hazards-protection disable
}
interfaces {
ethernet eth0 {
address ??.??.??.??/30
duplex auto
hw-id 00:25:90:37:41:1c
smp-affinity auto
speed auto
}
ethernet eth1 {
duplex auto
hw-id 00:25:90:37:41:1d
pppoe 0 {
default-route auto
mtu 1492
name-server auto
traffic-policy {
out PEERING
}

    }
    smp-affinity auto
    speed auto
}
loopback lo {
}

}
nat {
source {
rule 300 {
outbound-interface eth0
source {
address 10.99.99.0/24
}
translation {
address masquerade
}
}
}
}
policy {
route PEERING-LIST {
rule 100 {
destination {
group {
network-group PEERING-LIST
}
}
set {
mark 200
}
}
}
}
protocols {
static {
route 0.0.0.0/0 {
next-hop ??.??.??.?? {
}
}
}
}
service {

https {
    api {
        keys {
            id 1 {
            }
        }
        port 7000
    }
}
pppoe-server {
    access-concentrator SLBB
    authentication {
        mode radius
        radius-server ??.??.??.?? {
            secret localkey
        }
        radius-settings {
            acct-timeout 0
            nas-identifier VYOS_SLBB_NAS
            nas-ip-address ??.??.??.??
            rate-limit {
                enable
            }
        }
    }
    client-ip-pool {
        start 10.99.99.2
        stop 10.99.99.250
    }
    dns-servers {
        server-1 8.8.8.8
    }
    interface eth1 {
    }
    local-ip ??.??.??.??
    service-name smartlink123
}
ssh {
}

}
system {
config-management {
commit-revisions 100

}
console {
    device ttyS0 {
        speed 9600
    }
}
host-name SLBB-NAS-TEST
login {
    user ??? {
        authentication {
            encrypted-password ****************
            plaintext-password ****************
        }
        level admin
    }
    user ???? {
        authentication {
            encrypted-password ****************
            plaintext-password ****************
        }
        level admin
    }
}
name-server 8.8.8.8
ntp {
    server 0.pool.ntp.org {
    }
    server 1.pool.ntp.org {
    }
    server 2.pool.ntp.org {
    }
}
syslog {
    global {
        facility all {
            level info
        }
        facility protocols {
            level debug
        }
    }
}
time-zone Asia/Kolkata

}
traffic-policy {
shaper PEERING {
bandwidth auto
class 14 {
bandwidth 10240kibps
burst 15k
match TESTING {
mark 200
}
queue-type fair-queue
}
default {
bandwidth 20480kibps
burst 15k
queue-type fair-queue
}
}
}

Hi @mahendra,

Can you please do

show configuration commands

for both the PPPoE Server and the PPPoE client?

That way I can check your configurations in my lab more easily.

Thank you

Hi Lorente,

Find below:

noc@SLBB-NAS-TEST:~$ show configuration commands
set firewall all-ping ‘enable’
set firewall broadcast-ping ‘disable’
set firewall config-trap ‘disable’
set firewall group network-group PEERING-LIST network ‘173.194.0.0/16’
set firewall group network-group PEERING-LIST network ‘74.125.0.0/16’
set firewall group network-group PEERING-LIST network ‘202.177.244.0/24’
set firewall group network-group PEERING-LIST network ‘124.155.0.0/16’
set firewall group network-group PEERING-LIST network ‘216.58.0.0/16’
set firewall ipv6-receive-redirects ‘disable’
set firewall ipv6-src-route ‘disable’
set firewall ip-src-route ‘disable’
set firewall log-martians ‘enable’
set firewall receive-redirects ‘disable’
set firewall send-redirects ‘enable’
set firewall source-validation ‘disable’
set firewall syn-cookies ‘enable’
set firewall twa-hazards-protection ‘disable’
set interfaces ethernet eth0 address ‘49.143.252.11/27’
set interfaces ethernet eth0 duplex ‘auto’
set interfaces ethernet eth0 hw-id ‘00:25:90:37:41:1c’
set interfaces ethernet eth0 smp-affinity ‘auto’
set interfaces ethernet eth0 speed ‘auto’
set interfaces ethernet eth1 duplex ‘auto’
set interfaces ethernet eth1 hw-id ‘00:25:90:37:41:1d’
set interfaces ethernet eth1 pppoe 0 default-route ‘auto’
set interfaces ethernet eth1 pppoe 0 mtu ‘1492’
set interfaces ethernet eth1 pppoe 0 name-server ‘auto’
set interfaces ethernet eth1 pppoe 0 traffic-policy out ‘PEERING’
set interfaces ethernet eth1 smp-affinity ‘auto’
set interfaces ethernet eth1 speed ‘auto’
set interfaces loopback lo
set nat source rule 300 outbound-interface ‘eth0’
set nat source rule 300 source address ‘10.99.99.0/24’
set nat source rule 300 translation address ‘masquerade’
set policy route PEERING-LIST rule 100 destination group network-group ‘PEERING-LIST’
set policy route PEERING-LIST rule 100 set mark ‘200’
set protocols static route 0.0.0.0/0 next-hop 49.143.252.1
set service https api keys id 1
set service https api port ‘7000’
set service pppoe-server access-concentrator ‘SLBB’
set service pppoe-server authentication mode ‘radius’
set service pppoe-server authentication radius-server 122.170.105.97 secret ‘localkey’
set service pppoe-server authentication radius-settings acct-timeout ‘0’
set service pppoe-server authentication radius-settings nas-identifier ‘VYOS_SLBB_NAS’
set service pppoe-server authentication radius-settings nas-ip-address ‘49.143.252.11’
set service pppoe-server authentication radius-settings rate-limit enable
set service pppoe-server client-ip-pool start ‘10.99.99.2’
set service pppoe-server client-ip-pool stop ‘10.99.99.250’
set service pppoe-server dns-servers server-1 ‘8.8.8.8’
set service pppoe-server interface eth1
set service pppoe-server local-ip ‘49.143.252.11’
set service pppoe-server service-name ‘smartlink123’
set service ssh
set system config-management commit-revisions ‘100’
set system console device ttyS0 speed ‘9600’
set system host-name ‘SLBB-NAS-TEST’
set system login user noc authentication encrypted-password ‘$6$wPdPXUEcZ$Q.aksYzaevq5676xF5n0bJRp8pcnvGIFRidSlXdFbuDrKEAy2YvGANw0sQikecpM5QzLHohjbLvBaAauFJdu50’
set system login user noc authentication plaintext-password ‘’
set system login user noc level ‘admin’
set system login user vyos authentication encrypted-password ‘$6$Du9fx1DRTx$RT.ekLj8O/RTgrnrLrEpRaSqWyBUa/dI7g/YRVLNU7O.oySOKw0CA6NNy0zbXD0lW.eKK6RXeCT65kIzyvYLt1’
set system login user vyos authentication plaintext-password ‘’
set system login user vyos level ‘admin’
set system name-server ‘8.8.8.8’
set system ntp server 0.pool.ntp.org
set system ntp server 1.pool.ntp.org
set system ntp server 2.pool.ntp.org
set system syslog global facility all level ‘info’
set system syslog global facility protocols level ‘debug’
set system time-zone ‘Asia/Kolkata’
set traffic-policy shaper PEERING bandwidth ‘auto’
set traffic-policy shaper PEERING class 14 bandwidth ‘10240kibps’
set traffic-policy shaper PEERING class 14 burst ‘15k’
set traffic-policy shaper PEERING class 14 match TESTING mark ‘200’
set traffic-policy shaper PEERING class 14 queue-type ‘fair-queue’
set traffic-policy shaper PEERING default bandwidth ‘20480kibps’
set traffic-policy shaper PEERING default burst ‘15k’
set traffic-policy shaper PEERING default queue-type ‘fair-queue’
noc@SLBB-NAS-TEST:~$