Resolved - Should BGP work between VyOS versions?


I have a VyOS box running 999.201710142137 and a box running vyos-1.2.0-rolling+201807200337.

I updated my rolling version to vyos-1.2.0-rc9.

BGP stopped working between the two boxes, no other changes were made other than the update to the vyos-1.2.0-rc9.

I rolled back from vyos-1.2.0-rc9 to rolling+201807200337 on my production router and BGP started working again to the other box.

Is this to be expected or is this a problem that should be investigated?

I.E., do I have to run the same version of VyOS on each box to be guaranteed that the BGP function will work?

If I have to run both boxes at the same version then I might be able to try that this weekend.

If people think it should work then what is best way to debug?

If it should work then I could try it again this weekend and try to debug if I had some instructions from someone on how to debug it.

If I should post the configs then I think I can do that as it is BGP between private networks so there should be nothing in the BGP config that showing other people would compromise security.

Thoughts? Pointers?

Thanks in advance.


What does the logs say? Did you get a pcap to see what the packets are doing?



Good question, I’ll have to check next time I give it a try.

I had just updated my main production router from vyos-rolling to vyos-1.2.0-rc9 and lost my BGP connection to the vyos-999.XXX router which was unexpected, it should “Just Work ™.” :slight_smile:

So I rolled back until I can take time to investigate.

I’ll investigate and report back the results.


Awesome! Let us know. I will need to roll out 1.2.0. I am setting up a test VM now.


I updated my production router to vyos-1.2.0-rc10 and rebooted and everything (except VXLAN, see VXLAN works on VirtualBox but not on KVM URL) seems to be working.

So either either the BGP issue was just a fluke or it was fixed in vyos-1.2.0-RC10.


Thanks for the update! Did the logs say anything with respect to KVM vs VirtualBox. Did you debug it?


No, I didn’t do any debugging.

I just tried again later on as indicated and it worked that time.