Rolling Release 1.3 & Stable 1.2.6S1 - Grub does not start automatically

Hello,

I am currently testing Vyos on a dedicated hardware. I have installed vyos-1.3-rolling-202012290217 . Unfortunately the grub does not start the system. It only works by confirming the enter key. The Grub config looks good so far. It says that it should start after 5 sec. Unfortunately, this does not work in the version on my hardware. I have already tested it on two devices. Both times completely reinstalled.
regards
Christian

I just upgraded to run the latest rolling on D525. The test is normal. The default startup time may be long. Wait patiently

I waited for several minutes. :wink: Maybe a UEFI problem?

Okay have just tested both. Both pure legacy and pure UEFI do not work. So that can’t be the problem.

Which hardware?
Do you use supermicro?

No a NRG Systems IPU675

https://www.ipu-system.de/produkte/ipu675.html

I just upgraded today, because the image has a repair patch. It’s running normally, and I didn’t choose to boot manually

So I’m not sure what the problem is

Do you happen to habe a serial port connected?

There could be EMC sparks which trigger the commandöine to stop

No No serial interface connected. Although I have also tried with it…:wink:

Tomorrow I will still exchange the hardware. Before all keyboard, maybe that’s where a trigger comes from…

Okay. Unfortunately, nothing has led to success so far.
I have pulled off the keyboard and also replaced it. This has not helped. But when I boot e.g. from the Vyos installation stick, the timer works. There are 7 seconds counted down.

Is there any way I can test different things with Grup? update-grub has problems due to the overlay

/usr/sbin/grub-probe: error: failed to get canonical path of `overlay’.

One more addendum. A Debian 10.6 installation also boots automatically after installation. So there must be something in Vyos that prevents the automatic start.

Okay. And one more addendum. The Vyos 1.2.6 S1 does not work either.

I solve my problem myself :wink: If you activate the serial console redirection in the Bios it works. But you have to set the parameter Hide Setup item to Disabled under Advanced/OEM FORM. Then there is under Advanced the entry Serial Console Redirection.

Thanks for the posts and a happy new year!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.