Route Not Advertised via BGP in VRF

I have a subnet, let’s call it

Running VyOS 1.4-rolling-202211210318

So I’ve configured a prefix list:

set prefix-list pl_BGPv4_export rule 10 action 'permit'
set prefix-list pl_BGPv4_export rule 10 prefix ''

And then I configured a route map:

set route-map pol_BGPv4_export rule 10 action 'permit'
set route-map pol_BGPv4_export rule 10 match ip address prefix-list 'pl_BGPv4_export '

And then applied it to a neighbor:

set address-family ipv4-unicast nexthop-self force
set address-family ipv4-unicast remove-private-as
set address-family ipv4-unicast route-map export 'pol_BGPv4_export '
set address-family ipv4-unicast soft-reconfiguration inbound
set capability dynamic
set graceful-restart 'enable'
set remote-as '13335'
set solo

But when I run

It doesn’t show that I’m advertising any prefixes towards my peer, this configuration “was” working, previous, but then all of a sudden, just stopped?!

Also note, that BGP configuration is done under the edit vrf name external

Please specify the VyOS version

Apologies, 1.4-rolling-202211210318.

Is it directly connected network?
If yes, redistribute connected can help, if not there are other options

It is somewhat directly connected. I have subnetted the /24 into a local /26, with the remaining addresses being received via BGP.

Sorry, I’ve also configured aggregate-network as well. Have tried with both summary-only and not.

Have also tried configuring a blackhole static route for the /24 and redistributing static routes as well, but alas to no avail.

One thing I also noticed, and I don’t know if this is a thing or not, but if I run

show ip bgp vrf name prefix-list pl_BGPv4_export

I get a “prefix-list not found”

So just to update the situation. It looks like there might be some bug with the VRF not seeing the route-map or prefix-list.

How I had this configured, was within the VRF construct. As what we had done, was created 2 VRF’s, one for management and the other for transiting traffic.

I’ve now moved the transit traffic out of the VRF and into the default instance, and from there, everything works as expected.

Just curious to know to what extent should dynamic routing be working with VRF’s, and whether or not this is a bug that can be logged?


regarding this command:

show ip bgp vrf name prefix-list pl_BGPv4_export

it’s enabled when configure a prefix-list over address-family , So, in your case , it’s inside a RM , so it shouldn’t show anything.

show bgp vrf XXXX ipv4 neighbors xx.xx.xx.xx

using this command, you’ll see your current route-map over the specific peer :

  Inbound path policy configured
  Route map for incoming advertisements is *RM-XXXX

Hi there,

Sorry, yes and as well, when I’ve done the route-map equivalent as well, returns the same cannot find route-map error as well, even through the route-map is configured and applied.

run this command , check if all configuration was applied on FRR-CLI

sudo vtysh -c " show running"


Sorry, was on my production edge router. Had to revert moving the config out of the VRF into the default VRF.

Also no longer running 1.4-rolling and now running 1.3.x whatever is the latest build that’s available.