Rsyslog via IPv6


do any of you use rsyslog over IPv6?

I just can’t get it to work with VyOS.
I have the same rsyslog server in use with other Debian systems and it runs without issues, so I suspect the problem is with VyOS.

What version are you running? Could you also provide your config and any logs?

Show version
show conf com| match log

The system is running on the current rolling release (VyOS 1.4-rolling-202303050317)

The syslog config:

set system syslog global facility all level 'info'
set system syslog global facility protocols level 'debug'
set system syslog host facility all level 'all'
set system syslog host facility all protocol 'udp'
set system syslog host port '514'

The domain has an A and a AAAA record.
I have also tried with an literal IPv6 address.

The only thing that has worked so far is with a domain that only has an A record or an IPv4 address.

  • Are your other Debian servers using ipv6?
  • Can you monitor traffic and find what is sending your router as syslog info
    sudo tcpdump -i dst port
    For example: sudo tcpdump -i eth1 dst 10::2 port 514
    Wait some time or you may just add/edit description to some interfaces
  • Check