Run monitor webproxy access-log

Running version: VyOS 1.4-rolling-202206270217

When I run the run monitor webproxy access-log command I’ll get the following result back:
WebProxy cache-log does not exist.

I’ve setup the Vyos webproxy to forward all requests to a parent cache-peer; so I could expect that the access log is empty; however the message that is returned indicates the command requests the cache-log…

Can you show your webproxy configuration?

Here you go!

webproxy {
        cache-peer {
            http-port 3128
        listen-address {
            port 3128
        listen-address {
            port 3128

It looks like nothing went into the cache.
How did you check the Webproxy?

I ran the run monitor webproxy access-log command and the cache-log Equivalent, both turn up empty; but both show the same output as stated earlier.

It is a bug. I created bug report T4513

1 Like

Awesome; thank you very much!

This bug was resolved. So you can test in the next rolling release. Thanks for helping us find bugs.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.