Set interface wireless wlan0 disable

I used the wireless interface on my VyOS box as a client for the first time when my main internet dropped out, and it worked great… (later one day I’ll look into the WAN load balancer stuff so I can automagically start using my tethered phone next time the internet drops…)

But when I went to disable the wlan0 interface but leave the config there, using the disable command like I would for an ethernet interface, the “disable” config option was not available?
Is this a bug or ommission? or is there a better way to go about this.



which version of VyOS are you using? The Wireless interface has undergone a huge rewrite to the new config backend and a disable option is availble in latest rolling releases.

Hi, I’m using VyOS 1.2.4
if the disable option is in the rolling release, then great, I expect I’ll get it soon.

I can confirm bug, seems disable for wlan does not work even in latest rolling

vyos@WIFI# run show version | grep Version
Version:          VyOS 1.3-rolling-202003051936
vyos@WIFI# run show configuration commands | grep wlan0
set interfaces wireless wlan0 address 'dhcp'
set interfaces wireless wlan0 disable
set interfaces wireless wlan0 security wpa passphrase 'XXXXX'
set interfaces wireless wlan0 ssid 'test'
set interfaces wireless wlan0 type 'station'
vyos@WIFI# sudo ip addr show dev wlan0
5: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether cc:cc:02:84:cc:cc brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic wlan0
       valid_lft 172535sec preferred_lft 172535sec
    inet6 fecc::821f:2ff:fecc:cccc/64 scope link 
       valid_lft forever preferred_lft forever