SIT tunnel down

I am using 1.4-rolling-202111090317-amd64 and is trying to get a HE-tunnel running. I use the configuration from “Configuration Blueprints”. It does not work. When I look at the interfaces with the command “ip a” I get

7: sit0@NONE: mtu 1480 qdisc noop state DOWN group default qlen 1000
link/sit 0.0.0.0 brd 0.0.0.0
8: tun0@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1472 qdisc noqueue state UNKNOWN group default qlen 1000
link/sit 83.x.y.z peer 216.66.80.90
inet6 2001:470:27:ea6::2/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::53fb:6138/64 scope link
valid_lft forever preferred_lft forever
inet6 fe80::fc6c:54ff:fefc:2443/64 scope link
valid_lft forever preferred_lft forever

sit0@NONE is DOWN! How can I bring it up? At this moment no traffic pass through the tunnel.

Hello @Hubertus , I have the running VyOS router version 1.4-rolling-202111290926 which is connected to HE and works without issues.

set interfaces tunnel tun0 address 'xxx:xxx:xxx/64'
set interfaces tunnel tun0 encapsulation 'sit'
set interfaces tunnel tun0 remote 'y.y.84.46'
set interfaces tunnel tun0 source-address 'x.x.x.246'

Please verify your configuration regarding this article Tunnelbroker.net (IPv6) — VyOS 1.3.x (equuleus) documentation

Hello!

I have verified the settings several times without finding any mistakes. There is a difference between 1.3 and 1.4 regarding “protocols static route6”.

The strange thing is that the tunnel worked earlier. It seems to be a problem with this rolling version. Maybe I should try the version you are running.

Hi @Hubertus , please try the latest rolling version.
Yes, ipv6 statuic route also required
set protocols static route6 ::/0 next-hop xxx:xxxx:xxxx:xxxx::1

Hi, I made a fresh install of VyOS 1.3.0-rc6 and configured a tunnel to tunnelbroker.net. This time I got a slightly different message but the sit-tunnel is still down.

7: sit0@NONE: mtu 1480 qdisc noop state DOWN group default qlen 1000
link/sit 0.0.0.0 brd 0.0.0.0

As I have no possibilities to tune the configuration I am beginning to think of a bug.