SNMP server not listening on all interfaces

I configured SNMP server, but it only listens on interfaces other than management interface that is in its own VRF. If I do "set service snmp vrf ‘MNGMT’ " then it’s only listening on management interface and not on any other.

Is it possible to make SNMP server listen on all interfaces, regardless of VRF or not?

Cheers and thnx, Jan Zorz

Try it:

set vrf bind-to-all

Hi, thnx for your answer. This looks like a slick solution, but it doesn’t work :slightly_frowning_face:

I tried with adding this setting to vrf and then both ways of running SNMP - in “default” VRF and with “vrf MNGMT” setting, but to no avail. In both cases SNMP ran just where it was configured - or in “default” VRF or in MNGMT VRF. I also tried to reboot router between changes and commits, but nothing changed.

Cheers, Jan