Source Nat on PPPoE interface


#1

Hi,
i’m quite new to VyOS, and this is my first post here.

Here is my problem (VyOS Version 1.1.8):
I wanted to set up a pppoe connection and then enable source NAT. But i can’t select the pppoe connection as outbound-interface:
Could someone point me to my error?

Here is the configuration i have so far:

[code]admin@vyos# sh
interfaces {
ethernet eth0 {
address 192.168.16.77/24
hw-id 08:00:27:83:20:4c
}
ethernet eth1 {
hw-id 08:00:27:30:fe:1a
pppoe 0 {
default-route auto
password testpwd
user-id testuser
}
}
loopback lo {
}
}
+nat {

  • source {
  •    rule 100 {
    
  •        source {
    
  •            address 192.168.16.0/24
    
  •        }
    
  •    }
    
  • }
    +}
    service {
    ssh {
    port 22
    }
    }
    system {
    config-management {
    commit-revisions 20
    }
    console {
    device ttyS0 {
    speed 9600
    }
    }
    login {
    user admin {
    authentication {
    encrypted-password “”
    plaintext-password “”
    }
    level admin
    }
    }
    ntp {
    server 0.pool.ntp.org {
    }
    server 1.pool.ntp.org {
    }
    server 2.pool.ntp.org {
    }
    }
    package {
    repository community {
    components main
    distribution helium
    url http://packages.vyos.net/vyos
    }
    }
    syslog {
    global {
    facility all {
    level notice
    }
    facility protocols {
    level debug
    }
    }
    }
    }[/code]

And here i try to set the outbound interface:

admin@vyos# set nat source rule 100 outbound-interface Possible completions: <interface> Interface name or "any" any eth0 eth1 lo

Hopefully there is someone here that spot my error.

Thanks in advance!

Best regards
Simon


#2

Is there really no one that tried to do a source-nat on a pppoe interface and is able to give me some pointers?


#3

Have you tried committing the change and saving, then trying to set your masquerade rule?

Everything I am seeing shows that it should work.


#4

Hi,
sorry for the late answer. A friend and I finally found out the reason why it didn’t work.
We had to bring up (“connect”) the PPPoE from outside the configuration mode once. This works even if the PPPoE can’t really connect (i.e. the physical interface of the PPPoE was down).
It’s just very odd that a router should behave this way. What if i wanted to preconfigure a router in one go (an ISP for example)?

Thanks for your help anyway!

Regards
Simon