Ssh not responding

Hello folks,

I recently upgraded to the 1.4 rolling version, from a 1.3.2 version with the 1.4 kernel (for the i225v3 drivers)

My home router setup is with 2 VMs on 2 different boxes, that have either 6 or 4 physical interfaces and those interfaces are passed through to the VMs.
Those interfaces are i225v3 nics. I tried to not to pass them through, but CPU usage spiked and also the speed test graph didn’t look as nice.
Those interfaces are bridged together. I also have multiple VLANs and the default route for those VLANs is through VRRPs.
I also have some IP addresses that aren’t through VRRP, through which I usually connect to each router - 192.168.1.1/192.168.1.2. To connect to each of them I just proxy the connection through the default VRRP address.

On the passive VMI I can’t connect to any of the local IP addresses via ssh.
image
LE: here’s a tcp dump:
image
LE2: If ssh on the active router, but on the specific IP (not the VRRP one) then it behaves as if there’s an MTU issue.
My config is over 1200 lines - so i’m not adding it.
Any advice?

Seems like you try to connect to passive VM from its own console.
Such packets won’t cross br0.2 , but enter on loopback interface.
This might explain tcpdump output:
On zone based firewall setup, such traffic needs to be explicitly allowed

Something fishy is going on…
Now it works:
image
I was also able to ssh into it, but as soon as typed a command it blew up.

basically it behaves as if i have an MTU issue.

And now it doesn’t. I feel like there’s something else happening.