System does not work after first reset power

I’m using version 1.3.2 of vyos.

After the first installation and reboot into vyos (normal command line login).

If you reset power(not reboot) at this time, the system will not boot properly, and it will show errors such as missing environment variables.

Note: The failure can be reproduced in the virtual machine

This issue happens after 1.3.2 installation? Without any configuration, just a power reset on a new 1.3.2 installation?

I confirm. This happens during the first boot after installation. You can login or not, just power off (stop) system. After that, if an error occurs, you can log in, but no commands work.

I test it on self build image form 2023.01.30.

Yes, there is no configuration and it is only for the first boot after installation.

Resetting the power only after the first boot causes this problem. conf command does not work, I tried to add some environment variables manually, but the problem does not seem to be completely solved.

Thanks for the info. I can confirm such problem on a fresh install of 1.3.2 in proxmox.

And same error on latest 1.4.
Both tests consists on same procedure:

  • Create VM on proxmox
  • Boot from live cd and install image
  • Once image is installed, reboot the system through command line.
  • When reboot is finished and login prompt is displayed, stop the VM through Proxmox GUI.
  • Few seconds later, start the VM
  • Login and test.

It’s something related to creating users.
Boot, working vyos, log in, add new user, commit, save, exit, stop / poweroff system.
On next boot error occur in migration script. If you log in with new user no command work, but log in as old user and all working fine.

@yann @pepe thanks a lot for the report!

I think, it should be fixed by this:

The fix seems to be working, tested on 1.3.