Trying to load config from old instance to new one


#1

I am trying to spin up a new instance of VyOS in AWS as we are moving all of our instances from dedicated to normal tenancy. At first I tried simply creating a new instance from an AMI I generated from the old one, but once it was up we were never able to connect to it. At the suggestion of a support person for VyOS I have now tried spinning up a new instance of VyOS from one of the community AMIs and then loading the config from the old one up onto the new one. I have moved all files referenced in the config from the old one to the new one, I have gone through the config and replaced all references to the private IP of the old instance with the new instance’s private IP, and done the same with the public IP. When I ‘commit’ the config after loading it the host name changes, and then the logs say:

“Stopping enhanced syslogd: rsyslogd.
Starting enhanced syslogd: rsyslogd.”

Then it goes no further, and requires a restart to be reachable again. Upon inspecting the vyatta-commit.log file I noticed a few additional log statements after the ones it showed me:

"[ interfaces ethernet eth0 address dhcp ]
Starting DHCP client on eth0 …

[ interfaces ethernet eth0 duplex auto ]
Cannot set new settings: Operation not supported
not setting autoneg"

Does anyone have any idea what might be causing this? Thanks.


#2

Okay, so after looking again I found a reference to the mac address of the old instance in the config file. I changed that and it made it alot further in the commit this time. Still failed, but at least it didn’t lock up and force me to restart the instance this time. Now it is telling me that my shared-secret-key-files are invalid, but I am not sure why because I just copied them from the old instance, and set the permissions on them exactly the same way. Can two routers not use the same secret-key-file for a vpn tunnel?