Unable to access Vyos/ Keyboard hangs at GRUB

Hi All,

This is very important.
My Vyos was rebooted and all the SSH-Keys got deleted. Now I am unable to access the Vyos router. The console asks for root user/ pass, default Vyos/Vyos not working.
I tried to reset the password vis GRUB, but as soon as I open the GRUB, keyboard hangs.

Please help how to resolve this. There is no way to access the router.

set service ssh ‘disable-password-authentication’

This has been enabled on the Vyos.

Hello @rituka, this is bare metal or VM? Do you use the serial port?
Which VyOS version was running?

Hi,

Thats a supermicro server where I have installed Vyos image.
Thats a helium 1.1.7 image.

Version: VyOS 1.1.7
Description: VyOS 1.1.7 (helium)
Copyright: 2016 VyOS maintainers and contributors
Built by: maintainers@vyos.net
System type: x86 64-bit
Boot via: image
HW model: Super Server

Regards
Rituka

1.1.x EOL, I think you need to update your router to the actual version.
Are you use PS/2 or USB keyboard? PS/2 Keyboard requires a reboot router.

Hi,

The route is a critical router.
I need to get the access of the router first.
I am using USB keyboard.
Will changing password in GRUB help? Why the keyboard hangs? Any idea?

I have an odd question, but did you try another keyboard?

Yes. 3 keyboards I tried.
Is there a way I can get the access to the Vyos, at least I can get the config.

The router however is up and running. Only I am unable to access it.

Maybe that’s just what happened, but as it is weird that SSH keys got deleted, maybe you can try to see what information you get starting with ssh -v upto ssh -vvv if needed.

Hi @s.lorente
Even to run this command I should have access to the Vyos.

I don’t have the access to the Vyos anyways.

Regards
Rituka

I didn’t mean to run any command in VyOS. I meant to get some information through verbose mode when SSH’ing into VyOS.

https://linux.die.net/man/1/ssh

But I’m sorry, I took for granted you were trying to SSH into VyOS from a terminal emulator of a Unix-like machine, without explaining or asking.

Can you do so? Maybe, by using that command, there is a chance you could get some information on what’s happening.

You would need to run ssh -vvv <user>@<vyos-address>
Something like:

ssh -vvv vyos@190.24.33.241