Unable to create VM with ova file in ESXi

Hey everyone,

I am trying to import the vyos-1.3.0-rc4-vmware.ova into a new virtual machine on VMware ESXi. When I try to do so I am met with a Line 149: Unsupported element ‘Reservation’. Does anyone know how to fix this issue?

I have tried older ova files and the same issue occurs. I have also tried to import the ova into virtualbox and export it again as a ovf file version 1 and 2, but that did not work as well.

Any help would be greatly appreciated. Thanks in advance!

Are you installing the vm while login directly in esxi? Can you try it from vcenter? As far as I remember, installing VyOS ova using vcenter, did work correctly.

I’m using VMware Fusion to run ESXi and then installing the ova directly on ESXi. I tried installing the ova file into fusion and was still met with:
Line 149: Unsupported element ‘Reservation’,
Line 158: Unsupported element ‘Reservation’,
Line 167: Unsupported element ‘Reservation’

Was trying to setup a virtual lab environment and the instructions showed them installing it directly onto EXSi. Any suggestions?

Try the OVFTOOL
https://developer.vmware.com/web/tool/4.4.0/ovf

When a developer exports a VM as an OVF often there are extra fields input for use. Normal usage of OVA/OVF file is deploy into a vCenter. You are importing into a type2 hypervisor (Fusion) it can work but might fail due to extra fields.

Import the OVA file into the OVFtool. There might be extra fields that Fusion does not now how to parse.
Good Luck!