Unable to update to any version newer than 1.5-rolling-202309280022 (vbash issue)


I tried to update my VyOS VM to the latest rolling version but I am not able to update to any version newer than 1.5-rolling-202309280022.

The update process itself to any newer version seems to work as it doesn’t produce any warnings or errors. When I login to newer versions I only have a standard linux bash an not the vbash.

My original running version was 1.4-rolling-202306290317. Since the update to the latest version wasn’t working, I tried to update by small steps to the latest version that is working. Now I am stuck to 1.5-rolling-202309280022.

Any idea how I can fix this issue or where to lock for any error logs?


Sounds like a similar issue discussed here:

1 Like

Thanks. I’ve subscribed to the task to see when it’s fixed.

The problem is with the pmacct package which contains the /home/admin directory which is not accessible to the admin user added in the configuration.

I have already reported this issue here:

1 Like

If you got some bugs open please a bug report on https://vyos.dev
We can’t fix bug until we don’t have a proper task number and steps to reproduce this bug.

Ah, so the issue only arises when the administrative user account is named admin which interferes with the pmacct package?

I’ll create another administrative account, delete the admin and try to upgrade to a newer version.

I was able to update to the latest 1.5 rolling version by creating an administrative user not named admin.

I’ll write an update to bug report T5652 with a reference to this topic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.