Using @ in Dynamic DNS Configuration

Hello All!

Using 1.4-rolling-202308011218, I used to use the following configuration to configure Dynamic DNS with namecheap using an @ record:

service {
dns {
dynamic {
interface “interface name”
service namecheap {
host-name @
login “domain name”
protocol namecheap
password “Password”

I’ve been modernizing my configuration a bit and when I try to set host-name to @, I get this error:

Host-name must be alphanumeric and can contain hyphens
Value validation failed
Set failed

Is this a bug, or do I need to be doing something differently?

The host-name value needs to be relaxed a bit. Fix coming up.

Thank you @indrajitr, Will the Phabricator be linked in so I can follow it?

Sure, here you are:

1 Like

Thank you!

I’ve gone and tried to test it.
It works when setting manually via: configure; set service dns dynamic name host-name @
but doesn’t work when being loaded from a file via a merge operation.

On version 1.5-rolling-202311160736

I made an account on phabricator so I could comment, I haven’t been approved yet

did you manage to get ddns working ?? if so can you guide me the process

@himurae I can’t say that my bug report is a good place to discuss how to set it up. Private message me and we can work it out or if you have a thread of your own we can discuss there.

@indrajitr I did some more testing, I forgot to run git pull on my ansible node. It works as expected.

1 Like