VRF no manual static/interface routing entry can be added

When creating an VRF and applying it to an interface you can’t add a static nor an interface routing entry to the VRF. It doesn’t matter if you apply the VRF to an interface or not the routing entries never get added.

We tried with the three latest rolling releases (26th, 27th, 28th December).

It is not working for us but maybe I am missing something.

Did you follow the guide on https://docs.vyos.io/en/latest/configuration/vrf/index.html?

I’m using this setup for quiet a while leaking multiple routes between VRFs and having static ones.

I followed the guide.

I guess I found the problem:

My interface looks like this:

ethernet eth2 vif 1000 address 10.180.1.241/24

Masquerading is activated and the connection to the Internet is working fine too.

But as soon as I set the VRF on the interface, I don’t have any internet anymore.

Thats why I tried to set the static route on the vrf:

set protocols vrf NAME static route 0.0.0.0/0 next-hop 10.180.1.241

But this is not working.

When I do the following:
set protocols vrf NAME static route 0.0.0.0/0 next-hop 10.180.1.240

I can see the static entry added. What did I do wrong? After enabling the VRF I lose the ability to reach my masqueraded gateway.