VxLAN's "link" option does not work


#1

First, here is the VyOS version I am using :

vyos@vyos:~$ /opt/vyatta/bin/vyatta-show-version Version: VyOS 1.1.0 Description: VyOS 1.1.0 (helium) Copyright: 2014 VyOS maintainers and contributors Built by: maintainers@vyos.net Built on: Thu Oct 9 22:27:26 UTC 2014 Build ID: 1410092227-af6433f System type: x86 64-bit Boot via: image

vyos@vyos$ uname -a
Linux vyos 3.13.11-1-amd64-vyos #1 SMP Wed Sep 3 20:04:22 UTC 2014 x86_64 GNU/Linux

When looking for possible options to the vxlan interfaces, completion only offers the following choices :

vyos@vyos:~$ configure
vyos@vyos# set interfaces vxlan vxlan0
Possible completions:
+  address      IP address
 > bridge-group Add this interface to a bridge group
   description  Description
 > firewall     Firewall options
   group        Multicast group address for this VXLAN interface [REQUIRED]
 > ip           IPv4 routing parameters
 > ipv6         IPv6 routing parameters
   mtu          Maximum Transmission Unit (MTU)
 > policy       Policy route options
   vni          Virtual network identifier [REQUIRED]


[edit]
vyos@vyos# set interfaces vxlan vxlan0

Digging around, I found out that the “link” directory for vxlan interfaces was not in the right place :

vyos@vyos$ cd /opt/vyatta/share/vyatta-cfg/templates/interfaces/vxlan
vyos@vyos$ pwd
/opt/vyatta/share/vyatta-cfg/templates/interfaces/vxlan
vyos@vyos# ls -l
total 2
drwxr-xr-x  2 root root   31 Oct  9 22:28 link
-rw-r--r--  1 root root 1071 Oct  9 21:20 node.def
drwxr-xr-x 12 root root  156 Oct  9 22:28 node.tag

I moved it into the node.tag directory :

vyos@vyos$ sudo mv link node.tag/
vyos@vyos$ ls -l node.tag
total 4
drwxr-xr-x  2 root root   31 Oct  9 22:28 address
drwxr-xr-x  5 root root   73 Oct  9 22:28 bridge-group
drwxr-xr-x  2 root root   31 Oct  9 22:28 description
drwxr-xr-x  5 root root   65 Oct  9 22:28 firewall
drwxr-xr-x  2 root root   31 Oct  9 22:28 group
drwxr-xr-x 10 root root  206 Oct  9 22:28 ip
drwxr-xr-x  8 root root  153 Oct  9 22:28 ipv6
drwxr-xr-x  2 root root 4096 Oct 30 05:21 link
drwxr-xr-x  2 root root   31 Oct  9 22:28 mtu
drwxr-xr-x  4 root root   62 Oct  9 22:28 policy
drwxr-xr-x  2 root root   31 Oct  9 22:28 vni

After which I could confirm the “link” option was choosable :

vyos@vyos# set interfaces vxlan vxlan10
Possible completions:
+  address      IP address
 > bridge-group Add this interface to a bridge group
   description  Description
 > firewall     Firewall options
   group        Multicast group address for this VXLAN interface [REQUIRED]
 > ip           IPv4 routing parameters
 > ipv6         IPv6 routing parameters
   link         Underlay device name of this VXLAN interface
   mtu          Maximum Transmission Unit (MTU)
 > policy       Policy route options
   vni          Virtual network identifier [REQUIRED]

[edit]
vyos@vyos# set interfaces vxlan vxlan10

#2

It looks like that fix made it into the 1.1.1 maintenance release.

http://bugzilla.vyos.net/show_bug.cgi?id=381

http://vyos.net/wiki/1.1.0/release_notes#1.1.1