VyOS from usb stick?


#1

I have used Linux USB Creator and Universal USB Installer to make a bootable thumb drive, but I keep getting the same error “Unable to open ‘/dev/sdc’.” Does anyone know how to successfully create a bootable USB stick with VyOS? I am not trying to use the stick to run the OS, but to install onto a new machine. I don’t want to create a DVD for something this small.


So, I tried using a virtual machine to install on the USB stick, but it gives me the same error, “unable to open ‘/dev/sdc’.” It seems it has a problem reading the USB when it is the actual installation source? This is weird, I would think it would be like any other linux flavor and it would run just fine off of USB.


#2

this has worked for me every time.


#3

Hi
My Video record: http://fatihusta.com/2015/01/5-vyos-serial-port-install-and-usb-disk/


#4

I found this old thread, but I am having same exact issue. I used Rufus on my Windows system to,make bootable usb for the VyOS install and it boots to where I hit enter then when it tries to load it can’t fine sda, sdb, sdc and after trying dozens of times then says it failed. I can’t figure this out. I can create other bootable USB sticks for windows and they boot. Any ideas?


#5

did you use ‘dd mode’?


#6

I started with ISO mode then tried DD mode, but DD mode the usb drive doses nto even show as an option in the boot menu. Was I supplied to use DD mode, I can try again.


#7

OK I have made progress. I downloaded the latest night beta and it boots fine, so clearly the 1/1/7 version does not like something about my hardware. I noticed 1.1.7 is over 18 months old. Any idea when a newer stable version will be available? Also any way to use the new ISO to install the older image?


#8

#9

OK, I am moving along and discovered a few things. First the last stable build will not install no matter what I do. I think it is getting hung up with the Intel Raid controller. If I use the lastest nightly builds I till get further along it winds up disabling my BIOS based mirrored drives and takes one offline and installs to the other then works fine, but I no longer have Raid. If I just use the Intel controller with 2 independent drives it lets me pick one and install, but no option during the install even to enable OS based Raid. Oddly if I remove one drive and try the install it goes to,install and asks me if I want to Raid my main drive with the usb stick, of course I say no. Seems very odd and I will test some more.


#10

Intel raid is considered ‘fake-raid’ It is not a true hardware raid. DO NOT USE IT.


#11

It might be fake raid, but it does provide some redundancy economically. For my server I use LSI raid adapter, but for VyOS router I was hoping this would work. For now I am running VyOS in a Hyper-v VM, but will like go bare metal with a single Crucial SSD and gamble that it will work without issue.


#12

instead of using fakeraid, why not use mdraid that VyOS and the underlying Debian provide? It is much much better than any Intel fakeraid


#13

Isn’t mdraid going to be a problem if the primary drive fails since it can’t boot automatically from the secondary drive?


#14

??

You just need to install grub to both disks and it will boot from either one