Vyos ipxe install on Equinix bare-metal; does not complete reboot after install

Hi!

Struggling here with a vyos PXE install for an Equinix bare-metal server.
I was successfully able to build the iso and setup an ipxe server to host it.
Booting up the Equinix host works, it drops me into the expected live terminal, and I complete the install as seen below:


router01 login: vyos
Password: 
Linux router01 4.19.125-amd64-vyos #1 SMP Fri Jun 5 22:12:12 UTC 2020 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
vyos@router01:~$ install image
Welcome to the VyOS install program.  This script
will walk you through the process of installing the
VyOS image to a local hard drive.
Would you like to continue? (Yes/No) [Yes]: 
Probing drives: OK
Looking for pre-existing RAID groups...none found.
You have two disk drives:
	sda 	480103 MB
	sdb 	480103 MB
Would you like to configure RAID-1 mirroring on them? (Yes/No) [Yes]:
This process will erase all data on both drives.
Are you sure you want to do this? (Yes/No) [No]: Yes
Deleting old partitions on drive sda
Deleting old partitions on drive sdb
Looking for config files from previous installations on sdb1...
I found the following installed system image(s) with config files on sdb1:
  1: 1.4-rolling-202110120918
Would you like to save config information from it? (Yes/No) [Yes] No
OK.  Config information not saved.
Creating data partition: /dev/sda1
sfdisk: change-id is deprecated in favour of --part-type

The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.
Creating data partition: /dev/sdb1
sfdisk: change-id is deprecated in favour of --part-type

The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.

Erasing any previous RAID metadata that may exist on /dev/sda1
mdadm: Unrecognised md component device - /dev/sda1
Erasing any previous RAID metadata that may exist on /dev/sdb1
mdadm: Unrecognised md component device - /dev/sdb1
Creating RAID-1 group on partitions: /dev/sda1 /dev/sdb1
mdadm: /dev/sdb1 appears to contain an ext2fs file system
       size=468849664K  mtime=Tue Oct 19 12:08:31 2021
Continue creating array? mdadm: array /dev/md0 started.
RAID-1 group created successfully:
	md0 : active raid1 sdb1[1] sda1[0]
	      468847552 blocks [2/2] [UU]
	      [>....................]  resync =  0.0% (39552/468847552) finish=197.4min speed=39552K/sec
Creating filesystem on /dev/md0: OK
Done!
Mounting /dev/md0...
What would you like to name this image? [1.3-rolling-202006081325]: 
OK.  This image will be named: 1.3-rolling-202006081325
Copying squashfs image...
Copying kernel and initrd images...
Done!
I found the following configuration files:
    /opt/vyatta/etc/config/config.boot
    /opt/vyatta/etc/config.boot.default
Which one should I copy to md0? [/opt/vyatta/etc/config/config.boot]: 

Copying /opt/vyatta/etc/config/config.boot to md0.
Enter password for administrator account
Enter password for user 'vyos':
Retype password for user 'vyos':
Setting up grub: OK
Done!
vyos@router01:~$ reboot
Are you sure you want to reboot this system? [y/N] y

But it hangs after reboot, getting stuck at the grub boot options.
Ive tried installing on a single disk, and allowing it to setup raid, and two different ipxe servers with (1.4 and 1.3), I still get stuck at this point.
Please how can I fix this?
Its kind of urgent, and Ive been stuck here for nearly two weeks :slight_smile:
I have to add I wouldnt mind paid support to get this done, but I am still waiting for feedback.

It was the ‘black screen’ known issue described in Installation — VyOS 1.4.x (sagitta) documentation.
Interesting that its not happened to my PXE installs before now.
Also I do not see how to permanently fix it

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.