VyOS Not Acquiring DHCP IP Automatically

I am having trouble with VyOS (version 1.4) as it does not seem to be able to obtain an IP address from DHCP on startup unless I run dhclient with root privileges. I have verified that my DHCP server is functioning properly.

Can someone please help me understand why VyOS is not able to obtain an IP address automatically and suggest any potential solutions to this issue?

Which 1.4 version do you have?

How does your current config look like?

show conf commands | strip-private

Possible for you to do tcpdump on the uplink (like through switch or wiretap or so) to verify that the VyOS doesnt send a DHCP-request when booting?

I wanted to let you know that it was a false alarm.
I reviewed the commands shown by "

show conf commands | strip-private

and it didn’t show

set interfaces ethernet eth0 address ‘dhcp’.

it looks like I didn’t run the save command after committing the changes. I ran a test on another VyOS instance, and it appears to be working fine now.