VyOS not getting a WAN DHCP IP


Brand New to VyOS ( sort of ). I been using an edge router for some time and wanted to move over to VyOS as that platform is dying. Everything is going great, however, I just can’t seem to get one of my ISP’s working with VyOs.

I have virtualized VyOS using Proxmox… I have an External switch that is carrying two vlans for each of my ISPs. I trunk this up to my Proxmox host and then split it back out there.

However for the life of me I can’t seem to get a DHCP request from one of the ISP’s modems. My Tmo isp works just fine. I actually move that isp from one network port to another one to verify my config… The DHCP request follows and shows up in the VyOS interfaces ( eth1 to eth2)… So It looks to be working across my interface config.

The COX isp ( which doesn’t work in VyOS) works just fine in my edge router when I move that back. I’m guessing there might be some setting I might have to check out or try. Any suggestions would be helpful.

Or would this be something where VyOS won’t grab an DHCP as I already have a WAN with DHCP and it doesn’t want to confuse itself?

Thank you!

well , if you have a VM running inside Proxmox , there will be check if the vlan tag is working properly , are you able to configure an IP address static from VM with VyOS and reach router ? also, you could check using a monitor session if a DHCP request is getting on your WAN interfaces on VyOS :


Is 2nd DHCP locked to old router-MAC address by the ISP?

I changed the mac to match that of what I had in the old router… Once I did that… I was tried to staticly assign the ip to the interfaces and even ping the gateway. But it won’t let me out

Thank you @fernando … I tried your suggestion of trying to use a static ip and I’m able to ping the gateway but not go beyond that. I got the ip information from the old router to try. I also added the used the same mac address as the old router to try to see if that would help and… It didn’t

In the packet capture I keep seeing this

15:37:08.722099 IP > BOOTP/DHCP, Request from 78:45:58:86:cc:f2 (oui Unknown), length 300.

So it looks like it’s going out and trying to get a DHCP. I don’t ever remember needing to do anything on the ISP side when I switched routers before…