VyOS Subnet Issues


#1

Hi there,

I’m trying out VyOS for the first time but I’m having a bit of trouble tying everything together in order to be able to mimic a network for training purposes.

Here is my setup:

I have 3 interfaces on VyOS , 1 for each subnet:

eth0 --> dhcp (out to main LAN/internet)
eth1 --> 192.168.217.1/24
eth2 --> 192.168.247.1/24

These parts work:

VyOS can ping each interface for eth1 & eth2, but it cannot ping eth0 (192.168.0.1)
VyOS cannot ping the hosts in each subnet, nor the default gateway/internet addresses.

The hosts cannot ping any internet address, nor can they ping the interface or any host of the other subnet. It can only ping it’s own subnet’s interface.

I have added a static route and a NAT source rule but I’m still not having any luck (I’ve attached a screenshot showing this).

What do I need to do to make this work? I have been looking at numerous tutorials & other posts but it’s still not working for me which is very frustrating! I have a suspicion that I’m not setting up my routing protocol correctly, but any help would be greatly appreciated!

Thanks in advance.


#2

do you have eth0 set to receive a DHCP address? what address does it get? you don’t need a static interface-route, and you probably don’t need a static route 0.0.0.0/0 because you would assume the DHCP server on 192.168.0.0/24 would hand out a default route with the address lease it gives you…


#3

Hi,

Thanks a lot for replying. Eth0 is 192.168.0.24/24 - I have also removed both the static route and static interface-route but I’m still having the same issues. I can now ping my ‘real’ default gateway successfully however. When I ping Google from VyOS, it resolves to the IP address but I get the ‘Destination Host Unreachable’ message. Do I need to do something on my physical router to allow the traffic through?


#4

what is the output of
ip route


#5

Hi,

The output is attached. Looks like no packets are getting through eth0. Thanks again!


#6

Ok, a little update - I can now ping web addresses from VyOS, but I still cannot connect to the internet from hosts within the subnets, nor can I ping the hosts from VyOS, or even ping other hosts in other subnets. I have enabled pinging in the firewall on the clients.
I’m genuinely stuck and I don’t know what to try next; I thought this was supposed to be relatively straightforward!
The latest change I have made is attached.


Here is my new IP route screenshot…


#7

You are missing a default route, which means any traffic bound for non directly attached subnets will have no way of routing. I think it’s strange that the DHCP server does not hand out a default route with the address lease. You can try setting the default route under set system gateway address


#8

Hi jl3128,

Thanks for the suggestion mate. Unfortunately it hasn’t made a difference, still no connection to the internet from the VM clients. I don’t really know where to go from here to be honest.
I’ve attached a screenshot of the settings I have for one of the internal clients; I think I have set it up correctly. Do you think VMWare Workstation could be the problem? I was tempted to use Hyper-V instead as it seems people have more success with that.