Vyos to cisco GRE with ISIS

I am working on replacing some cisco routers with Vyos. One of the configs i’m working on that I can’t seem to get working is a GRE tunnel with ISIS runing on it. The GRE tunnel is up and working, but I can not get the ISIS to come up. From the cisco side it looks like a MTu issue, but can’t seem to get them to agree on a config. Any ideas or some place I can read up more on it? I am very new to Vyos.

Rec serial IIH from Tunnel (Tunnel1), cir type L1L2, cir id 00, length 1476
Sending serial IIH on Tunnel1, length 1513

VyOS:
set protocols isis interface tun0 network point-to-point
set protocols isis interface tun0 no-three-way-handshake
set protocols isis log-adjacency-changes
set protocols isis lsp-mtu ‘1473’
set protocols isis metric-style ‘wide’
set protocols isis net ‘49.0010.0023.2495.4a42.00’
set interfaces tunnel tun0 address ‘172.16.254.2/30’
set interfaces tunnel tun0 encapsulation ‘gre’
set interfaces tunnel tun0 ip
set interfaces tunnel tun0 multicast ‘enable’
set interfaces tunnel tun0 remote ‘y.y.y.y’
set interfaces tunnel tun0 source-address ‘x.x.x.182’
set interfaces tunnel tun0 source-interface ‘eth2’

Version: VyOS 1.4-rolling-202201180317
Release train: sagitta

Built by: autobuild@vyos.net
Built on: Tue 18 Jan 2022 03:17 UTC
Build UUID: d50ca037-29e1-45b8-ac09-22e642ca4e97
Build commit ID: 52f75193f3afe7

Architecture: x86_64
Boot via: installed image
System type: bare metal

Hardware vendor: LENOVO
Hardware model: 10AAS3YH00
Hardware S/N: MJ02JLVN
Hardware UUID: 0b645448-0611-11e5-b2f5-780b77e81200

Cisco:
interface Tunnel1
ip address 172.16.254.1 255.255.255.252
ip mtu 1476
ip router isis
tunnel source GigabitEthernet0/3.2
tunnel destination x.x.x.182

router isis
net 49.0001.aaaa.aaaa.aaaa.00
metric-style wide
log-adjacency-changes
redistribute static ip

I think you have to use “gretap” as for ISIS you need Ethernet over gre

1 Like